Another Yashica question/issue...

Discussion in 'Rangefinder Forum' started by cepwin, Aug 2, 2012.

  1. cepwin

    cepwin Member

    Messages:
    336
    Joined:
    May 26, 2012
    Shooter:
    35mm
    I just received a Yashica electro that I purchased from ebay. What I'm noticing is different than what was posted recently.
    1. The battery test light goes on but I've never seen the yellow or red lights go on
    2. I'm not noticing a duel image when I focus... I see the yellow boarder but it never looks out of focus...am I doing something wrong or is it not functioning?
    3 The shutter appears to fire...I'm not noticing issues of it staying on like the gentleman earlier.

    Is this also the pad of death?
    I"m in the process of shooting a role with it to see what I get.

    Thanks!
     
  2. zsas

    zsas Member

    Messages:
    1,961
    Joined:
    May 12, 2011
    Location:
    Chicago, IL
    Shooter:
    35mm RF
    Re item 2) Does this help, there is a small video of a flower being focused...
    http://wkoopmans.ca/notebook/?p=5537

    Not sure re the other items...sorry, hope it works out for you....
     
  3. kanzlr

    kanzlr Subscriber

    Messages:
    76
    Joined:
    Mar 2, 2012
    Location:
    Vienna, AUST
    Shooter:
    Multi Format
    re 1) try to reverse the battery.

    Both of my Electros (original silver and a GT) show the behaviour that the battery test light only works if the battery is inserted the wrong way, the exposure meter only works if I flip the battery around...do not ask...maybe thats because of the adapter, or the different battery or something else...

    2) try putting your finger in front of the smaller window (not the one with the mini aperture, thats the CdS meter) and look through. It COULD be that some mirror is missing, but I doubt it.
    3) the shutter fires even with the pad of death being death. Its just not as accurate any more.
     
  4. cepwin

    cepwin Member

    Messages:
    336
    Joined:
    May 26, 2012
    Shooter:
    35mm
    Thank you for your responses!. Yes zsas, that does help a lot....I see what one is supposed to be looking for. Thank you! Kanzlr, interesting..I'll have to try that...yeah I guess the adapter and the different battery would have an effect.