Battery Check Button on Electro35???

Discussion in 'Rangefinder Forum' started by joeyk49, Sep 27, 2005.

  1. joeyk49

    joeyk49 Member

    Messages:
    1,325
    Joined:
    Jan 13, 2004
    Location:
    New Jersey,
    Shooter:
    Multi Format
    What is it supposed to do when pressed?

    I just installed a fresh battery, with my homemade adapter and got no response when I pushed this button.

    I attached a flash unit to it and it fires...I assume that the camera's got power; am I right?

    Joe
     
  2. eumenius

    eumenius Member

    Messages:
    768
    Joined:
    Jan 6, 2005
    Location:
    Moscow, Russ
    Shooter:
    Medium Format
    It's supposed to light a small lamp in a frame counter window - if it fires, then the battery is OK and your camera would do automatic exposure. If the lamp don't respond, the lamp can be bad - it's common with these :sad: Or something is wrong with the checker circuitry, located under the lower cover of your camera.

    Cheers from Moscow,
    Zhenya
     
  3. joeyk49

    joeyk49 Member

    Messages:
    1,325
    Joined:
    Jan 13, 2004
    Location:
    New Jersey,
    Shooter:
    Multi Format
    Light comes on in the frame counter window, flash fires...I just burned a quick roll of 12 to see how we did

    The only problem now it that my big slr fingers keep grabbing the aperture ring to focus....ooops!

    Thanks.
     
  4. JHannon

    JHannon Member

    Messages:
    969
    Joined:
    Sep 7, 2002
    Location:
    Boston, MA
    Shooter:
    Multi Format
    There are two different designs, I have both types.. Push the battery test and a small lamp next to it lights. The other type battery test button lights the film counter as yours does.

    The "over" and "slow" lamps should also light depending on the shutter and light conditions. You push the shutter part way down to see this.

    These are very nice cameras with sharp lenses. The battery is the only fault with this camera.

    Regards,
    John
     
  5. joeyk49

    joeyk49 Member

    Messages:
    1,325
    Joined:
    Jan 13, 2004
    Location:
    New Jersey,
    Shooter:
    Multi Format
    The light functions are being a bit finicky, but the camera seems to work well. I get a lighted arrow in the viewfinder when the shutter is depressed halfway and the flash fires via the pc cord (at all shutter speeds, I think.).

    The only real problem I had was in rewinding. It seems that the release button on the bottom of the camera doesn't want to stay in. I pressed and strarted rewinding and felt the film tear inside. Opened the camera in a changing bag and found it torn with most of it still on the take up spool. Do I have to continuously hold down the release button when rewinding?

    I developed what was left of the roll and am fairly impressed (with the camera, not my photographic ability). They seem nicely exposed and pretty sharp! I think I just found my Go Anywhere Camera...
     
  6. JHannon

    JHannon Member

    Messages:
    969
    Joined:
    Sep 7, 2002
    Location:
    Boston, MA
    Shooter:
    Multi Format
    On my cameras the rewind button pops out when the film is loaded. To rewind I just press the button once and the button stays in. Then I just turn the rewind crank.