Bronica SQ-A 120 Back problems

Discussion in 'Medium Format Cameras and Accessories' started by mayowaxadelugba, Jun 20, 2013.

  1. mayowaxadelugba

    mayowaxadelugba Member

    Messages:
    5
    Joined:
    Jul 19, 2012
    Location:
    Upstate NY
    Shooter:
    Medium Format
    I'm not positive as to why this could be happening but I am unable to switch out the back that is on my camera right now and put another one on. There is film loaded into it, the slide is in, the multiple exposure lever is off, the mirror lock up lever is in the N position...is there something else that could be preventing me from taking it off?
     
  2. Alex Muir

    Alex Muir Member

    Messages:
    406
    Joined:
    Dec 23, 2009
    Shooter:
    35mm
    I haven't had this problem with mine. The safety mech, however, is operated by inserting and removing the darkslide. I suspect it is a simple mechanical latch. Do you have another back to examine? That would at least let you see how it operates, and possibly identify the fault. Alex
     
  3. Alex Muir

    Alex Muir Member

    Messages:
    406
    Joined:
    Dec 23, 2009
    Shooter:
    35mm
    Another thought. Is the darkslide the right way up? The grey ones have a circular mark on the end. That should be at the top of the slot for it to work properly. Alex
     
  4. mayowaxadelugba

    mayowaxadelugba Member

    Messages:
    5
    Joined:
    Jul 19, 2012
    Location:
    Upstate NY
    Shooter:
    Medium Format
    Jeez now I feel like an idiot haha the slide was in the wrong way....thanks Alex!