Bronica SQ-A finder going bad

Discussion in 'Medium Format Cameras and Accessories' started by revdocjim, Jan 10, 2011.

  1. revdocjim

    revdocjim Member

    Messages:
    357
    Joined:
    Nov 17, 2010
    Location:
    Tokyo
    Shooter:
    Multi Format
    The AE finder on my SQ-A has started to give inaccurate readings, leading to photos that are 1-2 stops underexposed. It was working fine as recently as this past summer. I have cleaned all the contact points on the finder and body and lenses, and confirmed that it does this with multiple lenses. Is there anything else I can do myself before giving up and shopping for a new finder or sending it in for repairs? What causes these meters to go bad?
     
  2. CGW

    CGW Member

    Messages:
    2,797
    Joined:
    Apr 19, 2010
    Shooter:
    Medium Format
    No clues on causation. I know competent repair options are scarce for Bronica but Koh's can usually fix sick SQ gear:

    http://kohscamera.com/

    Otherwise, you may be ahead shopping for a new AE finder. Sorry
     
  3. NJS

    NJS Member

    Messages:
    125
    Joined:
    Nov 13, 2009
    Shooter:
    Medium Format
    have you checked if the problem is not actually with the back instead of the prism?
     
  4. revdocjim

    revdocjim Member

    Messages:
    357
    Joined:
    Nov 17, 2010
    Location:
    Tokyo
    Shooter:
    Multi Format
    Oh, I forgot to mention that. I have 3 backs and I get identical readings with all three...
    I've also checked the battery.