Bronica SQ-A shutter speed dial not clicking

Discussion in 'Medium Format Cameras and Accessories' started by dancluff, Oct 26, 2011.

  1. dancluff

    dancluff Subscriber

    Messages:
    78
    Joined:
    Aug 18, 2011
    Location:
    Halifax, NS
    Shooter:
    Multi Format
    Hello I have recently bought a Bronica SQ-A and put about 2 rolls of film though it. When I bought it I bought the waist level finder and I also got one of the chimney finders. The chimney finder has a meter so I have been using that more. Recently I put on the waist level finder and went out on a hike. When I was about to take my first photo the shutter speed dial was making a bit of a weird sound. I moved it a bit more and then no sound. It seems that I can still change the shutter speed it just does not click into position. I have seen someone else on the web indicate the same problem but said that after a couple of shots the shutter just satyed open. So my question is: has this happened to anyone else and if so what did you do about it?
    I appreciate any info on this
     
  2. CGW

    CGW Member

    Messages:
    2,797
    Joined:
    Apr 19, 2010
    Shooter:
    Medium Format
    Bronica SQ series bodies aren't the easiest for DIY fixes. Sounds like a detent mechanism is worn out/broken. Koh's is among the few who service Bronicas reliably in N. America. No clue where you're located.
     
  3. dancluff

    dancluff Subscriber

    Messages:
    78
    Joined:
    Aug 18, 2011
    Location:
    Halifax, NS
    Shooter:
    Multi Format
    I am in Canada on the east coast (Nova Scotia) so I will check them out.
    Thanks for the info