Canon EF gods helllpppppp

Discussion in '35mm Cameras and Accessories' started by j-dogg, Dec 10, 2010.

  1. j-dogg

    j-dogg Subscriber

    Messages:
    1,320
    Joined:
    Jun 26, 2010
    Location:
    Floor-it-duh
    Shooter:
    Multi Format
    I have a 28-90 and an 80-200 that throw the Canon screen of death on my Rebel DSLR and a Canon EOS 650. My Nifty Fifty and Tamron 18-270 are fine. I get it if I step down my F-stop especially. It seems to be random but most common at f8.

    Contacts are cleaned. halp!
     
  2. Whiteymorange

    Whiteymorange Member

    Messages:
    2,385
    Joined:
    Jul 27, 2004
    Location:
    Boston area
    Shooter:
    Multi Format
    Perhaps the wrong forum for a question like this? I'm sure more digital types would have quicker and better answers
     
  3. hpulley

    hpulley Member

    Messages:
    2,214
    Joined:
    Oct 6, 2010
    Location:
    Guelph, Onta
    Shooter:
    Multi Format
    Hey, I have a 650 and a 28-80 II with exactly this problem so it is the right place to ask :smile:

    The death is a problem with the aperture. Either the motor is dead or the lubrication on the blades is seized up or moisture has gotten in there.For such cheap lenses as the 28-90 (or my 28-80 II) it isn't likely worth repairing them but if the 80-200 is the "magic drainpipe" then it is likely worth having fixed.

    Temporarly stop-gap measure is to use the lenses wide open or often I find if you put them at f/22 and press the DOF preview a zillion time it will work out the problem if it is mostly a lubrication issue. If the aperture motor is dead of course it won't help.
     
  4. j-dogg

    j-dogg Subscriber

    Messages:
    1,320
    Joined:
    Jun 26, 2010
    Location:
    Floor-it-duh
    Shooter:
    Multi Format
    I hear clicking on the 80-200, it's the 4.5 slowmatic version. I think both lenses are fucked.
     
  5. hpulley

    hpulley Member

    Messages:
    2,214
    Joined:
    Oct 6, 2010
    Location:
    Guelph, Onta
    Shooter:
    Multi Format
    Aperture motors are probably dead, sorry about your luck, problem with the EF mount all electric everything. They aren't the most expensive lenses at least.
     
  6. MattKing

    MattKing Subscriber

    Messages:
    16,793
    Joined:
    Apr 24, 2005
    Location:
    Delta, BC, Canada
    Shooter:
    Multi Format