Canon T70 jam?

Discussion in '35mm Cameras and Accessories' started by Athiril, Jan 31, 2014.

  1. Athiril

    Athiril Subscriber

    Messages:
    2,887
    Joined:
    Feb 6, 2009
    Location:
    Melbourne, V
    Shooter:
    Medium Format
    Cousin got a Canon T70.

    Mirror was stuck up, managed to get it to return.

    Fresh batteries are in, it displays the 3 bars for battery, and the rectange, but it doesn't display anything else, like 'program' for example, when you press the shutter nothing happens, it then beeps rapidly. Regardless, of whether I load film or not.

    Any idea?
     
  2. Athiril

    Athiril Subscriber

    Messages:
    2,887
    Joined:
    Feb 6, 2009
    Location:
    Melbourne, V
    Shooter:
    Medium Format
  3. AgX

    AgX Member

    Messages:
    11,176
    Joined:
    Apr 5, 2007
    Location:
    Germany
    Shooter:
    Multi Format
    It should work in all modes now, even without film.
     
  4. Athiril

    Athiril Subscriber

    Messages:
    2,887
    Joined:
    Feb 6, 2009
    Location:
    Melbourne, V
    Shooter:
    Medium Format
    It doesn't.
     
  5. AgX

    AgX Member

    Messages:
    11,176
    Joined:
    Apr 5, 2007
    Location:
    Germany
    Shooter:
    Multi Format
    I understood that. But even a broken door-switch will not produce that error. So there must be a fault in the electronics, or a major mechanical fault. Seen the price of these cameras I think saving this camera for parts is the best your cousin can do with it.
     
  6. Jeff Kubach

    Jeff Kubach Member

    Messages:
    6,932
    Joined:
    Sep 29, 2007
    Location:
    Richmond VA.
    Shooter:
    Multi Format
    Look up the T-90. Good prices.

    Jeff