Compur problem

Discussion in 'Large Format Cameras and Accessories' started by egdinger, Oct 18, 2006.

  1. egdinger

    egdinger Member

    Messages:
    108
    Joined:
    Sep 28, 2005
    Shooter:
    Multi Format
    I just got a camera and lens with a compur shutter. The shutter will sometimes fire as soon as I cock it. Does it just need a cla or is it something more serious?
     
  2. Ole

    Ole Moderator Staff Member Moderator

    Messages:
    9,281
    Joined:
    Sep 9, 2002
    Location:
    Bergen, Norw
    Shooter:
    Large Format
    Sounds like a CLA to me. The release isn't engaging properly every time, and like most intermittent problems it's probably due to gunk.
     
  3. don sigl

    don sigl Member

    Messages:
    306
    Joined:
    Jul 6, 2006
    Location:
    Durham, NC
    Shooter:
    Multi Format
    An overhaul would probably take care of this, but you could try cocking the shutter while opening the shutter for focus. I'm not that familiar with Compur, but I have had success with this method with older Ilex, kodak, and copal shutters. The method is to open the shutter while cocking and then close the shutter. The shutter will remain cocked and you will be set to go.
     
  4. BradS

    BradS Subscriber

    Messages:
    4,219
    Joined:
    Sep 28, 2004
    Location:
    S.F. Bay Area
    Shooter:
    4x5 Format
    I had the exact problem with a Synchro-Compur recently. Set it to Carol for routine maintenance (a CLA) and it works perfectly now....well, high speeds are way slow but, I guess that is to be expected for these older Compurs.
     
  5. egdinger

    egdinger Member

    Messages:
    108
    Joined:
    Sep 28, 2005
    Shooter:
    Multi Format
    Don that won't work. At least not on this, it only has a 'T' setting to open the shutter. There is no open lever like on newer shutters. I forgot to mention that this is a dial set compur. Good to know it's just something a cla will take care of!