Compur shutter

Discussion in 'Large Format Cameras and Accessories' started by Drew B., Jul 4, 2014.

  1. Drew B.

    Drew B. Subscriber

    Messages:
    1,981
    Joined:
    Feb 25, 2005
    Location:
    The Cape
    Shooter:
    Multi Format
    I have a speed graphic camera with a primotar 135 lens on a Compur (Deckel-Munchen) shutter. For some reason I can't cock the shutter if set on Time or Bulb...! Am I not doing something...some interlock mechanism not being switched? Any help would be greatly appreciated...!
     
  2. Fotoguy20d

    Fotoguy20d Subscriber

    Messages:
    1,234
    Joined:
    Jan 23, 2008
    Location:
    NJ
    Shooter:
    4x5 Format
    Don't force it or you'll break it. They're not supposed to be cocked for t or b. Just try firing the shutter - it should work properly without being cocked.

    Dan
     
  3. Zathras

    Zathras Member

    Messages:
    554
    Joined:
    Nov 9, 2004
    Location:
    SF Bay Area
    Shooter:
    Multi Format
    To add to Dan's post, I just wanted to mention that in addition to firing the shutter, Press and hold the shutter release for "B". The shutter will close as soon as you remove your finger from the release lever or the cable release. For the "T" setting, press the shitter release once to open the shutter, and press it again to close it. Should wourk just fine.
     
  4. Drew B.

    Drew B. Subscriber

    Messages:
    1,981
    Joined:
    Feb 25, 2005
    Location:
    The Cape
    Shooter:
    Multi Format
    Ok...you are correct! My other lenses don't work like that...they need to be cocked. This is great....:smile: