Durst Pictograph problems.

Discussion in 'Darkroom Equipment' started by adridimo, Feb 12, 2013.

  1. adridimo

    adridimo Member

    Messages:
    2
    Joined:
    Feb 12, 2013
    Location:
    Italy
    Shooter:
    35mm
    i'm writing you from Italy and I want to say sorry for my bad english.

    I have a Durst Pictograph AF enlarger and it has some problem, I think that maybe you can help me.

    The most important problem it's the Closed Loop system.

    1) if you set Yellow=0 and Magenta=124 the magenta filter is completely under the light. If you try to set Yellow=0 and Magenta= bigger than 124 the magenta filter will "chatter" (because it is already fully slotted in) and the controller returns "closed loop error".

    2) If you are printing and you set for example 15 second of exposure and than you press START, the timer starts at 23 second (more or less). This is not a density compensation but a closed loop controller and it's ok. I made some tests and they shows that this closed loop corrections are not repeatable. The closed loop try to compensate something but it do it not in the same way, it is not repeatable. The lamp is new and I am not able to understand why it is doing this.

    In Italy there no one that know how to fix these problems :sad:. I've tried even to call Durst Service but they said me that Pictograph is an old enlarger and they have no idea about it.

    It would be very nice also if someone has the pdf manual..

    I really hope that someone will help me.
     
    Last edited by a moderator: Feb 12, 2013
  2. Celepe

    Celepe Member

    Messages:
    28
    Joined:
    Jun 25, 2012
    Location:
    Paris (France)
    Shooter:
    Medium Format
    Hello,
    I just came across your post. I am the happy owner of a Pictograph too ! Did you solve the problems/questions you had ? Let me know. You will find almost everything available in terms of user's manual and service guide on this site :
    http://loremi.com/durst/
    Waiting for your answer.
     
  3. adridimo

    adridimo Member

    Messages:
    2
    Joined:
    Feb 12, 2013
    Location:
    Italy
    Shooter:
    35mm
    Hello Celepe,

    sorry for the late answer.

    Thank you very much for the link, I found very good materials in it.

    Do you have the same problems with your pictograph? I still have mine, but I think that with the service manual found in that link I can try to fix them.

    Are you able to find out spare parts for the pictograph?

    you can write me at adridimo(at)gmail(dot)com

    Thank you