Durst RCP50 ?

Discussion in 'Darkroom Equipment' started by Dave Dawson, Oct 11, 2009.

  1. Dave Dawson

    Dave Dawson Member

    Messages:
    178
    Joined:
    Feb 15, 2009
    Location:
    London UK
    Shooter:
    Medium Format
    In another moment of madness I have been on that dreaded auction site and bought a Durst RCP50 paper processor (well it was only £38:21p):smile: I won't be getting it until next month......Anyone used one?

    Cheers Dave
     
  2. mpirie

    mpirie Subscriber

    Messages:
    199
    Joined:
    Sep 19, 2005
    Location:
    Highlands of Scotland
    Shooter:
    4x5 Format
    Hi Dave,

    I haven't used the RCP50 but I have an RCP20 that I used regularly.

    I think I saw that one on the website but was put off by the need to "collect only".

    Mike
     
  3. Dave Dawson

    Dave Dawson Member

    Messages:
    178
    Joined:
    Feb 15, 2009
    Location:
    London UK
    Shooter:
    Medium Format
    I have now got the RCP 50 allthough I haven't set it up yet...Any tips anyone?

    Cheers Dave
     
  4. fdisilvestro

    fdisilvestro Member

    Messages:
    73
    Joined:
    Nov 23, 2005
    Shooter:
    Multi Format
    I have a RCP 40 VS, so these tips are based on my experiece
    Install and level.
    Before turning on, check condition of rollers and gears. Try to move the gears of each module to see if they turn (they might be a little hard to move).
    Next, fill all tanks with water. Don't put rollers in it yet. Check that there are no leaks, especially from the drain tubes. Turn it on (yes, without the rollers) and make sure the pumps are working and the motor is running (you should see the mechanical links where you connect the rollers rotating).
    Check the temperature with a termometer in each tank. Do not trust the temperature scale in the knobs. It takes some time to get to the usual RA-4 temperatures (maybe 20 minutes).
    There should be two buttons near the temperature knobs used to check if the working temperature has been reached or not. you may test it during this phase.
    If everything works fine, turn it off and put the rollers into the processor. Now turn it on again and check that all rollers are moving.
    You can try with a sheet of RC paper with emulsion side down. It may be a developed photo, just to check rollers are working fine.
    Next, an important consideration. At least with the RCP 40, there where at least 3 models. One model did not have variable speed, another with variable speed and another with different tank sizes (a smaller one for Bleach/fix). So the important thing is to make sure you model can work fine with RA-4
    If it has variable speed, then you shoud calibrate it so that developer time is correct (I think it is 45 seconds)
    If you are going to process B&W remember that it works only for RC paper. Adjust temperatures and times according to your process.
    The middle tank is for stop bath. Make sure you use stop bath and not water if you are going to use RA-4. Otherwise you may get color shifts.
    The processor should have an inner cover for the tanks/rollers and the outher cover. Without the inner cover it won't be light proof.

    Best of luck
     
  5. Dave Dawson

    Dave Dawson Member

    Messages:
    178
    Joined:
    Feb 15, 2009
    Location:
    London UK
    Shooter:
    Medium Format
    Thanks fdisilvestro...Having read the manual your suggestions are good and valid. The baths are 11 litres dev, 2.2L stop and 7L blix.

    My only concern is that I may have bought an oak tree when an acorn would have done!

    Cheers Dave
     
  6. Dave Dawson

    Dave Dawson Member

    Messages:
    178
    Joined:
    Feb 15, 2009
    Location:
    London UK
    Shooter:
    Medium Format
    I said...."My only concern is that I may have bought an oak tree when an acorn would have done!"

    Today I managed to get 'The oak tree' onto a bench..Levelled it, removed rollers, filled with water..no leaks :smile: and turned it on. Pumps sprang into life and the 8 degree C water :surprised: started to heat up. I didn't realise at first that the drive spindles were rotating until I wound the speed up but they were.

    So so far all seems to be ok.....I then ran out of time to test it any further so haven't measured the final temperature against my digital thermometer yet.
    The rollers are in good condition and can be manually rotated so it looks as though I may have a 'worker'

    Cheers Dave
     
  7. fdisilvestro

    fdisilvestro Member

    Messages:
    73
    Joined:
    Nov 23, 2005
    Shooter:
    Multi Format
    Good!
    I forgot to mention that the drive spindles rotate very slow if adjusted for RA-4
    If you are going to process color with RA-4, it is better to use the chemicals for Roller Transport processor (Kodak has the designation RT) since they will last longer than the chemicals made for minilabs (i.e. Kodak Prime SP).
    Anyway, unless you process a lot of prints, it will be difficult to exhaust the chemicals before they turn bad from oxidation (11 lts. of developer is a lot)

    Francisco