Elinchrom EL 500 says "no" ...

Discussion in 'Lighting' started by maarten m, Mar 10, 2012.

  1. maarten m

    maarten m Member

    Messages:
    227
    Joined:
    Apr 7, 2010
    Location:
    gent belgium
    Shooter:
    Medium Format
    fuse seems to be OK (put in a new one anyway, but doesn't change a thing)

    - i put in a new pilot-light, but it doesn't work
    - flashbulb doesn't fire (nor does the ready-light),
    - lights inside the on/off switch do work.

    condensors died? just broken? any ideas?

    maarten.
     
  2. John Koehrer

    John Koehrer Subscriber

    Messages:
    6,058
    Joined:
    Apr 3, 2004
    Location:
    Montgomery,
    Shooter:
    Multi Format
    Sounds expensive.
    If the ready light isn't lighting it suggests a problem in the charging circuit or capacitor, which agrees with you. I would expect the caps to be in parallel with the ready light so when the cap is charged, the light will glow.
    It does carry a pretty healthy punch and I wouldn't go poking around inside of it.

    John, Who has been bitten by caps a number of times. Slow learner.
     
  3. Leigh B

    Leigh B Member

    Messages:
    1,035
    Joined:
    Jan 17, 2011
    Location:
    Maryland, US
    Shooter:
    Multi Format
    Probably bad capacitor(s). These deteriorate with age, particularly if they sit unused.

    They're definitely suspect in any equipment over ten years old.

    It might be possible to revive them without destroying them as follows:
    At noon (or some other time of your choosing), turn the light on for ONE minute, then turn it off.
    Next day at the same time, turn it on for TWO minutes, then off.
    Next day at the same time four minutes, next day eight, etc.

    At the end of a week you're up to an hour. If it's going to revive it will have done so. If it doesn't work then, it's dead.

    If at any time you experience a problem like the fuse blowing or any unusual odor, turn it off and discontinue the process.

    - Leigh
     
    Last edited by a moderator: Mar 11, 2012
  4. sandermarijn

    sandermarijn Member

    Messages:
    770
    Joined:
    Oct 19, 2005
    Location:
    Leiden, Neth
    Shooter:
    35mm
    Title makes me think of Little Britain's "Computer says no" (http://www.youtube.com/watch?v=SNRGCPKhJFE)

    Sorry about the malfunction Maarten. I hate it when electronics die on me (with mechanical stuff you can at least have an illusion of being able to fix, sometimes, maybe). Good luck.