Flash problem with a Minolta X-370

Discussion in '35mm Cameras and Accessories' started by r1ma, Jul 15, 2010.

  1. r1ma

    r1ma Member

    Messages:
    35
    Joined:
    Mar 10, 2010
    Location:
    Sacramento,
    Shooter:
    Medium Format
    I picked up a X-370 for my mom and re-fomed it last week. Yesterday I got a lens from her in the mail to run some film through to see if I was successful. It was dark, so I broke out my modern flash (Nikon SB-80 ca. 2000). It fires the flash, and the shutter actuates, but the mirror doesn't return unless you turn off the camera!

    Just to be sure, I shot some hand held at 1/8s, and everything worked perfectly fine. The flash works fine on my Nikons and using a PC cord to my Mamiya.

    I'm hoping it's just an issue with new-fangled flashes, not the camera. This body will replace her SRT-101, which she's got a vintage Vivitar 285 for.
     
  2. Steve Smith

    Steve Smith Subscriber

    Messages:
    9,083
    Joined:
    May 3, 2006
    Location:
    Ryde, Isle o
    Shooter:
    Medium Format
    Sounds odd. Does the X-370 have a TTL type dedicated hot shoe or is it just the one centre contact? If it has other contacts then some of the wrong signals from the Nikon flash may be confusing it. I expect it would be o.k. with the 285.

    EDIT: Looking at the manual it does appear to have an extra contact. Try taping over it so it doesn't connect to the flash.

    http://www.butkus.org/chinon/minolta/minolta_x-370/minolta_x-370.htm


    Steve.
     
    Last edited by a moderator: Jul 15, 2010
  3. BradS

    BradS Subscriber

    Messages:
    4,219
    Joined:
    Sep 28, 2004
    Location:
    S.F. Bay Area
    Shooter:
    4x5 Format
    I have a Minolta X-370 and it has an extra contact on the hot shoe. I ssuspect that the fancy Nikon flash also has a pin that makes contact with that extra contact on the camera....and, of course, Nikon is not compatible with Minolta...so, you have a problem. The X-370 works fine with the simple one pin type flash equipment (I use a Vivitar 283 and a Sunpack 383). Viviatr also make a dedicated flash for the minolta X bodies....I think there was a version of the 2800 that was dedicated to Minolta x bodies...

    Anyway...try a simple flash like the Vivitar 283, etc.

    Hopefully, you have not damaged either camera or fancy Nikon flash.
     
  4. r1ma

    r1ma Member

    Messages:
    35
    Joined:
    Mar 10, 2010
    Location:
    Sacramento,
    Shooter:
    Medium Format
    Well the good news is that they both still work afterwards, and I never use the flash TTL anyway.

    Thanks for the help!
     
  5. Steve Smith

    Steve Smith Subscriber

    Messages:
    9,083
    Joined:
    May 3, 2006
    Location:
    Ryde, Isle o
    Shooter:
    Medium Format
    From what I can work out from the manual, the extra contact is to tell the camera that it has a Minolta flash fitted so I expect the flash either puts a voltage onto this pin or connects it to 0v. The camera detects this and sets the shutter to 1/60 (flash synchronisation speed). If the flash is putting a different voltage onto this pin it may well confuse the shutter. Probably not much potential for damage though.


    Steve.
     

    Attached Files:

  6. Christopher Walrath

    Christopher Walrath Member

    Messages:
    7,114
    Joined:
    Dec 30, 2005
    Location:
    In a darkroo
    Shooter:
    Multi Format
    It is the flash. It sends extra voltage that prevents the mirror from slapping back down. The best thing to do would be to get a more appropriate flash for the camera to prevent burning out a capacitor and rendering the camera useless without some 'kinda' major repair. This may never happen but why take chances. You can pick up a flash like the Vivitar 3800 I have used for years for under $20. Cheaper than the repair bill and less hassle than replacing the capacitor your self on the off chance that the worst does occur.
     
  7. r1ma

    r1ma Member

    Messages:
    35
    Joined:
    Mar 10, 2010
    Location:
    Sacramento,
    Shooter:
    Medium Format
    Ran through the rest of the roll this afternoon, no problems, and got it developed. Then there was problems. Consistently half frames :sad: The shutter only opens 1/3 the way.
     
  8. BradS

    BradS Subscriber

    Messages:
    4,219
    Joined:
    Sep 28, 2004
    Location:
    S.F. Bay Area
    Shooter:
    4x5 Format
    before you freak out and do anything rash...try putting a fresh battery in the camera.
     
  9. r1ma

    r1ma Member

    Messages:
    35
    Joined:
    Mar 10, 2010
    Location:
    Sacramento,
    Shooter:
    Medium Format
    New batteries, no help
    Popped off the bottom, nothing seems broken.

    Probably going to take it to a local guy and have him take a quick look, but unless it's really cheap to fix, I'll probably cut my very meager losses at get a new body.

    Really, I'm in to this body less than the value of a half a tank of gas so far. Not a big loss.