Have you experienced this

Discussion in '35mm Cameras and Accessories' started by North for Short, May 17, 2005.

  1. North for Short

    North for Short Member

    Messages:
    176
    Joined:
    May 14, 2004
    Location:
    Farnborough,
    Shooter:
    35mm RF
    Apart from the Air conditioning on the car, The fidge Freezer and the Dishwasher ALL packing up on the same weekend, (6th May 2005), I went to use my FM2. I carefully took it out of the case, set up the shot and with the MD12 attached, depressed the button and a super shot of kids playing football (soccer to you Americans) and whhhr, nothing happened. The power button was left on and when I removed it, I tried to use the built in light meter in the camera and nothing, de nada, zilch. I thought "marvellous, what else could go wrong"? :rolleyes:

    I rang a camera repair centre who were willing for me to give them £75 to have the camera repaired. at this moment in time, I have a bit of a cash flow problem, (there is no cash flowing) so I can't buy another battery for the camera to try out. Could the MD12 drain the cell battery within the camera or has the light meter just given up the ghost? I brought the Camera on Ebay and has been marvellous for the last two years. (love it to bits). If I do have to get the camera repaired, is ti worth it or should I look for another bargain on Ebay? I need help, please! :sad:
     
  2. TheMissingLink

    TheMissingLink Member

    Messages:
    133
    Joined:
    Sep 30, 2004
    Location:
    Hamburg/Germ
    Shooter:
    Large Format
    Take it as a sign: With a LF you wouldn't be on the horns of this dilemma;-)

    Give it a try with a battery, on ebay they sell some as a package for less money. My girl also uses such a modern thing with a power station and we pay more than 30 Eu for one battery at the shop ... on ebay 15 Eu for 6 pieces ...

    give it a try, selling the camera could be an option for later ...

    Horst
     
  3. skahde

    skahde Member

    Messages:
    427
    Joined:
    Feb 16, 2004
    Location:
    Germany
    Shooter:
    Multi Format
    The MD12 will not drain the battery on any camera it fits unless the button on the handle is constantly pushed dow or the contacts for the remote-control which are located at the lower part of the handle are shortcut by something. The latter happend to me with an FE2. I wouldn't worry to much about it as long as it doesn't happen again. Switch the MD12 to off as you put it away.

    If I understand this correctly, the camera fires the shutter and it is just the lightmeter which doesn't work, right?

    If you don't have money for a new battery learn to guess the exposure following the tables inside the film box. It is easier than you may think. You were clever enough to buy a camera which does not need batteries to take great photographs.

    Stefan
     
  4. North for Short

    North for Short Member

    Messages:
    176
    Joined:
    May 14, 2004
    Location:
    Farnborough,
    Shooter:
    35mm RF
    Thanks I think. The MD12 is normally switched off. If this happened last Friday, I would have had an excuse but the battery is virtually new (bought in February)
     
  5. Nige

    Nige Subscriber

    Messages:
    2,125
    Joined:
    Sep 8, 2002
    Shooter:
    Multi Format
    My MD12 is on the fritz at the moment... the battery contacts need a clean.
     
  6. John Koehrer

    John Koehrer Subscriber

    Messages:
    6,378
    Joined:
    Apr 3, 2004
    Location:
    Montgomery,
    Shooter:
    Multi Format
    north for short,
    Isolate the problem, Remove the MD12 & check the camera for operation. If it's a meter problem replace the camera battery(MS76's). When reinstalling the MD12 be sure both camera & motor are cocked. There was a sync problem with the MD11's that Nikon cleared up with the 12 but you never know.
    Oh yeah when the bodyis separated from the motor you may need to pull the advance lever away from the body to activate the meter.
     
  7. Lee Shively

    Lee Shively Member

    Messages:
    1,325
    Joined:
    Apr 4, 2004
    Location:
    Louisiana, U
    Shooter:
    Multi Format
    I agree. Remove the motor and try using the camera without it. Many of us at the paper where I used to work owned MD12's and they were persnickety at best. I got mine to work by giving it a good whack on several occasions.
     
  8. DKT

    DKT Member

    Messages:
    504
    Joined:
    Sep 19, 2002
    yeah--I worked at a paper when those things were new, and both were real buggy. the 12 won't drain the camera battery if you leave it on, the MD11 will though...I had both MD11s and 12s lock up while using them, and I can't really say which method worked best, but usually it was a combination of taking them off the camera, firing the camera body manually and then putting them back on and whacking the bottom of the drive a few times....sometimes, when the drive fails, the little pins aren't in the right orientation to fit the body, so you have to line them up, and you can also sometimes clean the contacts...I still have my MD11 from about 20 yrs ago and the thing has been almost dead for about ten years...it works for about 5 minutes and then freezes up....basically junk now.