Help with Canon AE-1

Discussion in '35mm Cameras and Accessories' started by Mike Kennedy, May 15, 2007.

  1. Mike Kennedy

    Mike Kennedy Member

    Messages:
    1,595
    Joined:
    Feb 5, 2005
    Location:
    Eastern Cana
    Shooter:
    Multi Format
    I just fixed a slow mirror return but now the meter flashes a red blinking light when it's activated. Did I cure the illness but kill the patient?

    Thanks Much
     
  2. Alex Hawley

    Alex Hawley Member

    Messages:
    2,894
    Joined:
    Jul 17, 2003
    Location:
    Kansas, USA
    Shooter:
    Large Format
    Mike, as I recall, the red light indicates under exposure. Did you try adjusting the shutter speed to change exposure? Also, check that you have the aperture ring set to "A" for automatic. If you have it set on an f number, the exposure is in the manual mode. Irregardless, the blinking light means that the exposure setting is too low.
     
  3. Mike Kennedy

    Mike Kennedy Member

    Messages:
    1,595
    Joined:
    Feb 5, 2005
    Location:
    Eastern Cana
    Shooter:
    Multi Format
    AE-1

    Thanks for that ray of hope Alex but every attempt to negate the flashing red light has failed.Guess when I repaired the mirror return gear the oil,yes one small drop of oil,must have shorted out the AE-1.DANG!
    Mirror snaps like it was brand new,but the "cure" blew out the AE-1's circuits.(I think).
    I shall lend my Nikon Fe to Jacqui until I can get her a replacement.Feel responsible for pronging her Canon.

    Mike