Issue with Nikkormat and Albinar ADG 28mm f2.8 Macro

Discussion in '35mm Cameras and Accessories' started by j-dogg, Nov 16, 2010.

  1. j-dogg

    j-dogg Subscriber

    Messages:
    1,320
    Joined:
    Jun 26, 2010
    Location:
    Floor-it-duh
    Shooter:
    Multi Format
    When I mount at f5.6 the indexing tab that tells the camera the max aperture of the lens only goes to like 3.5 after I set it. It will go to 2.8 if I open the lens to 2.8 but if I'm not shooting wide open, it will stay at 3.5

    I've tried mounting at f22 and nothing.

    EDIT If I slam the aperture into 2.8 it stays at 2.8, I think it might be a mount issue. hold on a min, I always fix shit minutes after I post on APUG
     
  2. David William White

    David William White Member

    Messages:
    1,179
    Joined:
    Jun 23, 2007
    Location:
    Hamilton, Ca
    Shooter:
    Multi Format
    The Nikkormat (and all pre-AI bodies) requires that you mount at 5.6, then immediately crank to min then max, so the body knows how wide you can go. So lock, go to f/22, then open to f/2.8. Then it's okay.

    Does that help, or did I misread and address the bleeding obvious?
     
    Last edited by a moderator: Nov 16, 2010
  3. j-dogg

    j-dogg Subscriber

    Messages:
    1,320
    Joined:
    Jun 26, 2010
    Location:
    Floor-it-duh
    Shooter:
    Multi Format
    Pretty much.

    I found a fix I have to crank a little hard on the aperture ring but it works. I have another lens that does it, a Rokinon but none of my Nikons do it, so I think I know what the problem is.