Issue With One of My A12 Backs

Discussion in 'Medium Format Cameras and Accessories' started by BradleyK, Nov 16, 2012.

  1. BradleyK

    BradleyK Member

    Messages:
    950
    Joined:
    Jul 14, 2011
    Location:
    Burnaby, BC
    Shooter:
    Multi Format
    I just pulled from the "darkroom" (a.k.a. the guest bathroom) eight rolls of film (FP4 Plus) that I processed earlier today; having shot the film over the course of the last two weekends, I decided to spend the evening getting caught up with my darkroom work. Cutting them into strips to fit my Printfile pages, I noticed something odd: the spacing between the images differs on several of the rolls. i.e. on five of the rolls, the space is a few millimetres, as is typical for the Hasselblad film backs; on three others, the spacing ranges from less than 2 millimetres to almost half-an-inch! What gives? Am I experiencing wear on the gears that transport the film? Is this typical? Is the issue repairable at a "reasonable" cost, or should I just pick up some replacements from KEH? Unfortunately, I can only isolate the problem down to four of my A12s (I use black for black and white...). Thus far, I have not lost any images due to the issue, but may run the risk of doing so if the problem worsens. Ideas?
     
  2. epig

    epig Member

    Messages:
    40
    Joined:
    Jan 6, 2005
    Shooter:
    Multi Format
    Send 2 at a time to David Odess or another well regarded tech for O/H. Better than buying some used unknown problem backs.

    Eric
     
  3. MattKing

    MattKing Subscriber

    Messages:
    17,197
    Joined:
    Apr 24, 2005
    Location:
    Delta, BC, Canada
    Shooter:
    Multi Format
    Contact Horst Wenzel - pm me if you need contact info.
     
  4. Sirius Glass

    Sirius Glass Subscriber

    Messages:
    20,728
    Joined:
    Jan 18, 2007
    Location:
    Southern California
    Shooter:
    Multi Format
    It is time for a CLA. You will find the investment in the CLA well worth it.