Konica Auto S2 + Copal shutters

Discussion in 'Rangefinder Forum' started by KarlrR, Nov 7, 2007.

  1. KarlrR

    KarlrR Member

    Messages:
    4
    Joined:
    Nov 7, 2007
    Shooter:
    35mm
    Hi all, just joined,

    I received a "everything appears to be working" Konica Auto S2 from ebay. Needless to say I was mad as *@$Xx* when I receive it yesterday, only to find the shutters/aps flopping about in the lens. And a loose lens barrel.

    I've stripped the lens apart. The glass is in fantastic condition for a 60s camera without a lens cap, not even cleaning marks. I'm down to the clockworks on each side of the shutter.

    I would like to see if I can repair the shutters and aperture, however I've never attempted this before nor do I have schematics. Can anyone help me out? Point me in the right direction? Any help at all.

    Do I have a paperweight? :confused:

    Thanks
    Karl
     
  2. monemmer

    monemmer Member

    Messages:
    9
    Joined:
    Jun 25, 2007
    Shooter:
    35mm
    Karl, I bought a parts/repair S2 off Ebay that was in similar condition to yours. With some help from the web I managed to completely resurrect it. I had to dismantle the lens and remove it from the camera to get to the aperture blades which were sticky. I cleaned those with q-tips dipped in charcoal
    lighter fluid until the aperture blades were snappy again when dry. After reassembling the lens I had to re-solder the wires leading to the cds cell (I cut them to get the lens off). After that, I re-glued the mirror in the rangefinder that had come loose and then cleaned the rangefinder with q-tips dipped in Windex and then adjusted it for proper alignment at infiity setting. After that it turned out that the battery test button contacts were corroded and I had to take the battery chamber apart to get to those to clean them. While I was working on that part, I soldered in a Schottky diode to adjust the camera to 1.55V silver oxide batteries. Now I am waiting for the new leatherette from cameraleather.com, and I will have a nice fully functioning Auto S2.

    Here are some useful links for your CLA project...

    http://flickr.com/photos/74695037@N00/1359936260/in/photostream/
    http://feuerbacher.net/photo/frame.html?repair/KonicaAutoS2/KonicaAutoS2.html~Main

    I hope you'll get yours going again.

    - Markus

    PS: I forgot to mention, that I also had to put some oil on the pivots in the frame counter mechanism, and the shutter lock mechanism that is underneath the plastic cover of the light meter (you'll have to take the top cover off the camera to see these).
     
    Last edited by a moderator: Nov 8, 2007
  3. polaski

    polaski Member

    Messages:
    104
    Joined:
    Feb 16, 2006
    Location:
    Philadelphia
    Shooter:
    35mm
    I have my first "serious" camera, a Konica S II my uncle brought back from Japan. The shutter is a weak point. I'll probably send it to Greg Weber.
     
  4. KarlrR

    KarlrR Member

    Messages:
    4
    Joined:
    Nov 7, 2007
    Shooter:
    35mm
    Thanks Gents,

    I already have the two refs noted. And they have been helpful. However, I'm now down to were I've separated the aperture and shutters. I'm worried that someone has done this before, since I suspect that there is a second brass screw missing from the aperture assembly. (blue arrow is one brass screw and silver tweezers point to another threaded hole I suspect I should find an other. I also noted that all the shutter and ap blades are stained with fingerprints.
    Sorry for the poor quality, it's a cell camera and I was just using them as a ref to help during rebuild.

    Any other ideas would be great.

    Thanks

    Karl
     

    Attached Files:

  5. monemmer

    monemmer Member

    Messages:
    9
    Joined:
    Jun 25, 2007
    Shooter:
    35mm
    Karl, I did not have to go as far as you did. I managed to clean the aperture blades without opening the shutter all the way. If you can move the aperture mechanism, repeatedly putting a few drops of naphta on the blades and wiping the blades clean with q-tips. It will only become 'snappy' when it is clean and completely dry. I use a can of compressed air to quickly dry off the naphta.

    Good luck - Markus
     
  6. KarlrR

    KarlrR Member

    Messages:
    4
    Joined:
    Nov 7, 2007
    Shooter:
    35mm
    Markus,

    Thanks, I was really hoping it was just a case of cleaning when I bought the camera. Sadly, it blades of the shutter and aperture were sliding around inside the lens when it arrived.
    I'll be working on it again this afternoon, wish me luck :smile:
     
  7. monemmer

    monemmer Member

    Messages:
    9
    Joined:
    Jun 25, 2007
    Shooter:
    35mm
    Karl, good luck, I hope you'll get it back together and working. I once completely took the shutter of an Olympus 3RC apart to fix shutter blades that were skewed, and got it back together. I am sure that I will never sell that camera.

    - Markus
     
  8. KarlrR

    KarlrR Member

    Messages:
    4
    Joined:
    Nov 7, 2007
    Shooter:
    35mm
    Well, after 3 attempts at re-assembling the shutter and aperture halves only to have the blades dis-lodge while re-assembly, I put the whole thing down and focused on cleaning the barrel and helical. Guess what I found? A matching brass screw for the aperture assembly... :smile:

    Once that was in, the two haves went together without further fuss. So I re-soldered the yellow sync flash wire and was pleased with the newly reassembled aperture / shutter assembly. Since I didn't have to dis-assemble and of the clock works for the self timer, shutter release, etc., I'm really hoping that I don't need to work on them.

    Time for two fingers of fine Inslay Scotch and ponder were the extra black screw came from which I ALSO found behind a brass cam while cleaning the lens barrel!!

    Karl
     
  9. monemmer

    monemmer Member

    Messages:
    9
    Joined:
    Jun 25, 2007
    Shooter:
    35mm
    Karl, that black screw might be one of the screws that secure the black covers of the rangefinder mechanism. One of them was missing on my S2.

    CHEERS!

    - Markus