Kowa 6 shutter release problem

Discussion in 'Medium Format Cameras and Accessories' started by midlife crisis, Apr 8, 2007.

  1. midlife crisis

    midlife crisis Member

    Messages:
    35
    Joined:
    Apr 5, 2007
    Location:
    Vale of the
    Shooter:
    Medium Format
    I was recently given a Kowa 6 which has pushed me into the world of medium format. It does appear to have one small problem in that quite often the shutter will not release even though the lock is in the correct position.

    Does anyone else use one of these cameras? Has anyone else experienced this problem? As I am a bit of a novice to medium format am I doing something wrong? Can anyone suggest a fix that does not include a large hammer?

    Regards
    N:confused:
     
  2. David Brown

    David Brown Subscriber

    Messages:
    3,574
    Joined:
    Feb 16, 2004
    Location:
    DFW, Texas
    Shooter:
    Multi Format
    I used these for years (until I got a Mamiya RB last year).

    If you're lucky, there is something not lined up. The shutter has to be set properly on the lens before it's mounted on the body. One picture being worth 1000 words, a look at the manual is in order. Hope this helps. :smile:

    http://www.butkus.org/chinon/kowa/kowa_66/kowa_66.htm
     
  3. midlife crisis

    midlife crisis Member

    Messages:
    35
    Joined:
    Apr 5, 2007
    Location:
    Vale of the
    Shooter:
    Medium Format
    Dave, thanks for the advice. I have been through the manual and I seem to be doing as it says. It does seem to work okay without the film loaded which worries me as that may suggest that the winding mechanism is not functioning as it should.
    I was given the camera in october and so far have only put six rolls through it so it may improve with use.
    The action of the shutter release locking ring feels a little vague so you really have to look to make sure the dots are lined up. This may suggest that all is not well with the locking ring.
    Regards
    N
    :smile:
     
  4. Moopheus

    Moopheus Member

    Messages:
    1,066
    Joined:
    Dec 31, 2006
    Shooter:
    Medium Format
    I have this problem with mine too--it seems to work best with a light touch applied straight down. But I haven't had it very long and have only run a few rolls through it so far, so I haven't had a chance to really investigate what's going on. Using a cable release seems to help somewhat.
     
  5. paul ron

    paul ron Member

    Messages:
    1,744
    Joined:
    Jan 22, 2004
    Location:
    NYC
    Shooter:
    Medium Format
    Does it still have the same problem when using a cable release?

    I've never had a Kowa but on some cameras I have worked on have a fire button adjsutment. Some just by turning the center buttom that screws in and out, other need a slight bending of the tab just behind the fire button. Perhaps taking off the bottom plate may reveal the trigger mechanism and there you will see a way to make the button more sensative?
     
  6. patrickjames

    patrickjames Member

    Messages:
    743
    Joined:
    Mar 25, 2005
    Shooter:
    Multi Format
    I seem to remember an issue with the Kowa 6 that involved the winding mechanism. If I recall correctly I fixed mine by removing the lens mount and moving the geared ring over one notch. Worked like a champ after that. I don't remember what the camera acts like before you do this though. From what I remember it wouldn't fire. I hope this helps.

    Patrick