LPL 7450 & Rodenstock Rodagan 150 Mounting Issue???

Discussion in 'Enlarging' started by CarlRadford, Nov 6, 2005.

  1. CarlRadford

    CarlRadford Member

    Messages:
    1,945
    Joined:
    Mar 7, 2005
    Location:
    Just outside
    Shooter:
    Multi Format
    Hi Folks,

    I have just acquired a LPL 7450MK2 and a 150mm Rodenstock Rodagon lens. However, I have no manual for the enlarger and cant find a download for it. The problem I have is that the lens mount that I was given with the enlarger appears too small for the aperature on the enlarger. The external diameter being about 87/88mm on the enlarger and approx 84/85mm on the mounting ring. The mounting ring appears to be exactly the same as that on my LPL7700. That said, I have mounted the slightly smaller mounting ring and used the screw tightener/clamp which just pushes the mount slightly off center.

    The next issue is that whilst the Rodenstock 150 lens does not appear to mount in the 39mm thread - the 80mm Rodenstock does no problem as do the Componons that I have.

    I am sure there are simple answers to these questions but I can't find them at present - any ideas/advice more than welcome!

    Cheers, Carl.
     
    Last edited by a moderator: Nov 6, 2005
  2. Ole

    Ole Moderator Staff Member Moderator

    Messages:
    9,281
    Joined:
    Sep 9, 2002
    Location:
    Bergen, Norw
    Shooter:
    Large Format
    "Enlarging" seems to me to be the correct category.

    I'll delete the other one.
     
  3. JohnArs

    JohnArs Subscriber

    Messages:
    1,075
    Joined:
    Sep 20, 2002
    Location:
    Switzerland
    Shooter:
    Multi Format
    Hi Carl

    For the 150 Rodagon wich I also have I got a large extention tubus 55mm long and 50mm lensmounting diameter to my enlarger and you can get them with a lens mounting for 39mm for 135mm lens and 42mm 50mm and 53 mm for 150mm lens.
    So you need to messure wich diameter you need to get the right lens mount!
     
  4. Nige

    Nige Subscriber

    Messages:
    2,128
    Joined:
    Sep 8, 2002
    Shooter:
    Multi Format
    I have the exact same issue. My (used) 7451 came with a lens in a mount that didn't fit the enlarger, but I had to use that board as the lens (ReproMaster 150/9) has a smaller thread than std! I had a shop machine the mount down to suit the 87/88mm requirement which worked ok. I then went and bought a 135/5.6 Rodagon and have been using the tub as used in the C7700 which as you mention mounts slightly off centre, however it seems to be ok. I've thought about inserting some filler material in front of the lugs it pushes against to realign it a bit but haven't got around to it.
     
  5. CarlRadford

    CarlRadford Member

    Messages:
    1,945
    Joined:
    Mar 7, 2005
    Location:
    Just outside
    Shooter:
    Multi Format
    Thanks folks...

    I'll track down somewhere that can fabricate a mounting ring for me.
     
  6. Dave Miller

    Dave Miller Member

    Messages:
    3,894
    Joined:
    Dec 22, 2003
    Location:
    Middle Engla
    Shooter:
    Medium Format
    There used to be some such around Luton way that advertised in AP. Manufactured adaptor rings to order. Sorry brain's gone again!
     
  7. Dave Miller

    Dave Miller Member

    Messages:
    3,894
    Joined:
    Dec 22, 2003
    Location:
    Middle Engla
    Shooter:
    Medium Format
    Remembered - SRB 01582 572471
     
  8. CarlRadford

    CarlRadford Member

    Messages:
    1,945
    Joined:
    Mar 7, 2005
    Location:
    Just outside
    Shooter:
    Multi Format
    Cheers David...

    I'll give em a go!!