Mamiya 6 50mm lens is difficult to Mount on the body

Discussion in 'Medium Format Cameras and Accessories' started by jd callow, Mar 12, 2004.

  1. jd callow

    jd callow Moderator Staff Member Moderator

    Jan 31, 2003
    Multi Format
    Good Day,
    I recently trashed my 2nd Mamiya 6 body ( it isn't completely gone but almost). I purchased and received a very nice example via Ebay. As I was attaching lenses and testing the new body I discovered that the 50mm is very difficult to attach. It is as hard to get it on my old body as it is for the new to me body.

    It will go in, but there is resistance as you turn (cw) to the lock position. I suspect the mount on the lens has been damaged/altered, but I can not detect how or what.

    I'm leaving for New Orleans Wednesday So I don't have time to send it to Mamiya -- unless I want to forgo the 50mm which is hardly an option.

    Does anyone have a suggestion or possibly could post a scan of the mount -- It is slightly different than the 75 and 150 (just as the 150 differs slightly from the 75).

    Any help will be appreciated.
  2. piniongear

    piniongear Member

    Mar 23, 2004
    I purchased my Mamiya 6 brand new when they first came out (several years ago) and there is even a warning in the instruction book regarding the installation of the 50mm.
    It has to be put on very straight and carefully. This is different that the 75 or 150, both of which can be rapidly inserted and twisted on. Take your time with the 50 however! This lens sticks further back into the camera body than it's two brothers.........................................piniongear