Mamiya RB 67 ProSD back problem?

Discussion in 'Medium Format Cameras and Accessories' started by outforlunch, Apr 25, 2012.

  1. outforlunch

    outforlunch Member

    Messages:
    3
    Joined:
    Apr 24, 2012
    Location:
    US
    Shooter:
    Medium Format
    I am new to this group and forum. I have always found answers on apug when googling problems. I decided to join since this seems to be the place to get reasonable and knowledgeable information.

    I have a Mamiya RB67 ProS. I recently got a ProSD back and have been using it. I really like the dark slide pocket. Everything seemed to be working fine but in the last week, every roll but one that I've developed has had one blank photo. The last roll had two in a row.

    I ruled out the lens by switching it. I took the back off and cocked and fired the camera about 20 times in a row. The shutter on the lens worked and the mirror in the camera worked as well.

    Could it be the back? What would cause a problem like this? I don't look at the counter every time I cock the film advance but when I do look, it seems to be working. Shows red for exposed and won't let me take another photo until I advance.

    Thanks for any light you can shed on this.
     
  2. paul ron

    paul ron Member

    Messages:
    1,864
    Joined:
    Jan 22, 2004
    Location:
    NYC
    Shooter:
    Medium Format
    Blank frames are the lens misfires otherwise if it were the back not advancing it would be a grossly over exposed double exposure. The back doesn't close on a frame or advance 2 frames at a time but a lens sometimes will not open properly... very common early symptom of an old lens in need of a CLA.

    Try firing the lens on camera with the back open so you can see it fire, do it several times to see if every shot is being exposed?

    Another mistake can be you advanced the frame twice before shooting n not realized you did this?... very common early symptom of old users in need of a CLA?

    .
     
  3. Moopheus

    Moopheus Subscriber

    Messages:
    1,086
    Joined:
    Dec 31, 2006
    Shooter:
    Medium Format
    Is it possible for the dark slide interlock to fail?
     
  4. paul ron

    paul ron Member

    Messages:
    1,864
    Joined:
    Jan 22, 2004
    Location:
    NYC
    Shooter:
    Medium Format
    NO. If the interlock wansn't working it would either not allow you to fire or just couldn't care if you fired or not.
     
  5. outforlunch

    outforlunch Member

    Messages:
    3
    Joined:
    Apr 24, 2012
    Location:
    US
    Shooter:
    Medium Format
    Thanks for the responses, everyone. I did check the lens with the back off. It seemed to be working. I fired it about 20 times. If I'm getting one blank per ten that should rule that out. You're right, paul ron. That also occurred to me. Older certainly fits and I've noticed when I get into a fixed habit of doing something a certain way, sometimes the brain cells don't register it. I call it the eye dee ten tee error. I will try another roll and be very alert as to what I'm doing this time. I mean when you're trying to get a close up of a flower bobbing in the wind and cursing at it like that's going to do something, anything can happen. :smile: