Mamiya RZ Pro hot shoe

Discussion in 'Medium Format Cameras and Accessories' started by Mats_A, Apr 20, 2011.

  1. Mats_A

    Mats_A Member

    Messages:
    571
    Joined:
    Jan 31, 2010
    Location:
    Finland
    Shooter:
    Multi Format
    I tried my Rz Pro today for the first time with a flash. I could not get it to fire from the hot shoe. I tried different flashes and non of them worked.
    I can't find anything in the manual that could cause this.
    Is there any Mamiya users here that could have idea about this. The battery is new and flashes will fire with a sync cord.
    The lens is a 180 mm RB lens. Could this cause the hot shoe not to function?

    Any ideas appreciated.

    r

    Mats
     
  2. brucemuir

    brucemuir Member

    Messages:
    2,265
    Joined:
    Dec 25, 2007
    Location:
    Metro DC are
    Shooter:
    Multi Format
    If you're using a RB lens my guess is you'd need to sync from the lens.
    Im not 100% sure if the sync signal comes from the body or the lens and I'm only using RZ glass on RZ1.

    Considering an RB lens won't "talk" with the camera this may be the reason you are having issues.
    I'm assuming you don't have an RZ lens to test the shoe with that?
     
  3. Mats_A

    Mats_A Member

    Messages:
    571
    Joined:
    Jan 31, 2010
    Location:
    Finland
    Shooter:
    Multi Format
    I was afraid this might be the case. At the moment I do not have a RZ lens to try it with but I might get one next week and will test your theory then.

    r

    mats
     
  4. polyglot

    polyglot Member

    Messages:
    3,470
    Joined:
    Jun 12, 2009
    Location:
    South Austra
    Shooter:
    Medium Format
    The RB lenses have no electrical contacts on the mount, therefore no way to communicate flash sync through the body to the hotshoe. You need to either sync from the lens' PC port or use an RZ lens.