Moskva 5 flash contact function

Discussion in 'Medium Format Cameras and Accessories' started by Murray@uptowngallery, Oct 28, 2006.

  1. Murray@uptowngallery

    Murray@uptowngallery Member

    Messages:
    1,041
    Joined:
    Sep 24, 2003
    Location:
    Holland, MI
    Shooter:
    Pinhole
    I accidentally discovered some strange behavior with my Moskva 5 yesterday.

    I put a cold shoe adapter on a bracket to use a Sunpak flash.

    At 1/50 second, the flash would only work maybe 1 out of 6 tries.

    I went to 1/25, not at all.

    I went to 1/100 and it worked several times in a row.

    Is this normal (aside from being normal to have many problems)?

    Thanks
     
  2. kb244

    kb244 Member

    Messages:
    818
    Joined:
    Dec 26, 2005
    Location:
    Grand Rapids
    Shooter:
    Multi Format
    Sounds like a bad contact in the lens, as such only a faster shutter speed would trip the flash sync hard enough to make contact. I'm in Grand Rapids area, you could always have me take a look at it (either on a personal basis, or can bring it into the store where I work cameracenter.net in the same area).

    But ya I'm thinking thats what it is, because normally it should fire all the time at any speed.
     
  3. Murray@uptowngallery

    Murray@uptowngallery Member

    Messages:
    1,041
    Joined:
    Sep 24, 2003
    Location:
    Holland, MI
    Shooter:
    Pinhole
    Are you at the Wealthy St "camera museum"?
     
  4. kb244

    kb244 Member

    Messages:
    818
    Joined:
    Dec 26, 2005
    Location:
    Grand Rapids
    Shooter:
    Multi Format
    That what they calling it down there? But ya its one and the same, off the corner of Wealthy and Lake Dr, with the thousand or so old cameras along the walls.