new camera= new issues Minolta X-300s

Discussion in '35mm Cameras and Accessories' started by Anayari, Jan 17, 2012.

  1. Anayari

    Anayari Member

    Messages:
    22
    Joined:
    Nov 30, 2011
    Location:
    Aguadilla, P
    Shooter:
    35mm
    HELP: new camera= new issues Minolta X-300s

    Hello everyone! I am back after a holiday in Florida and before I left I had ordered a Minolta X-300s on ebay for cheap with a macro lens. I can't find anywhere if to be able to shoot this one I need to have batteries on it or if it won't shoot because the shutter is broken or something since my other 35mms are fully manual and only use the batteries for the light meter I'm at a loss here. Then I accidentally dropped the poor thing and the focus screen fell out. I was able to put it back in but I have no idea if I placed it back correctly or if this was even supposed to be able to be put back in or I just placed it on wrong or if the fall affected anything else since I still have no batteries for it. Any insight will be valued and thanks in advance!
     
    Last edited by a moderator: Jan 17, 2012
  2. donkee

    donkee Member

    Messages:
    146
    Joined:
    May 3, 2011
    Location:
    Mid Michigan
    Shooter:
    Multi Format
  3. Anayari

    Anayari Member

    Messages:
    22
    Joined:
    Nov 30, 2011
    Location:
    Aguadilla, P
    Shooter:
    35mm
    Thanks so much for your help. I already have a manual and I swear to you I checked everywhere to see if it said if it would shoot without the baterry but nothing what worries me is that fall it had tonight and that the focus screen part fell off. I was able to put it back in but I'm not sure if it's going to stay there or if I even put it on correctly or if it will affect my pictures once I get some batteries on it :sad: Anyone knows if this is a big deal or if you can just put it back in and it will be ok? thanks so much!
     
  4. mr rusty

    mr rusty Subscriber

    Messages:
    760
    Joined:
    Sep 7, 2009
    Location:
    lancashire,
    Shooter:
    Medium Format
    This doesn't sound too good.

    I have an X300, and the focus screen (assuming you mean the screen inside the lens above the mirror) is not supposed to be removeable.

    You definitely need batteries for the X300 to function - it takes SR44. If, when you get batteries the LEDs inside the viewfinder come on, but go out when you press the shutter and the shutter doesn't fire, then it is suffering from a common capacitor problem which requires the replacement of a capacitor inside the base. Capacitors are cheap, but it takes a steady hand unsoldering and resoldering the replacement component. Def a DIY repair though.