Nikon F100 Battery Drain

Discussion in '35mm Cameras and Accessories' started by agfarapid, Dec 19, 2011.

  1. agfarapid

    agfarapid Subscriber

    Messages:
    191
    Joined:
    Nov 21, 2008
    Location:
    New England
    Shooter:
    Multi Format
    Just acquired a mint F100 from an estate. Ran a test roll, everything's fine. The only problem is that it eats batteries! I'll put a set of new alkalines in, dry fire a couple of shots, and the battery is completely dead. Switched batteries, tried some rechargeable ni cads--same problem. Any one else experienced this with this camera? BTW, in all my years of shooting 35mm, this is my first Nikon. Any suggestions out there?
     
  2. benjiboy

    benjiboy Subscriber

    Messages:
    8,531
    Joined:
    Apr 18, 2005
    Location:
    U.K.
    Shooter:
    Multi Format
    Excessive battery drain is usually due to an electrical fault, I suggest have the problem diagnosed and corrected by a professional camera technician.
     
  3. Terry Breedlove

    Terry Breedlove Subscriber

    Messages:
    134
    Joined:
    Jan 19, 2009
    Location:
    Forks, Wa
    Shooter:
    Medium Format
    I absolutely love my little F100 and the batteries last a long time. Have it checked or buy another on ebay they are cheap for what you get. Here is a photo of my little Granddaughter I took last week with the F100 and Nikon 80-200 f 2.8 ED. That camera and lens plus a 24 mm makes an awesome combination.

    [​IMG]
     
  4. John Koehrer

    John Koehrer Subscriber

    Messages:
    6,378
    Joined:
    Apr 3, 2004
    Location:
    Montgomery,
    Shooter:
    Multi Format
    This isn't going to help but I'm curious.

    I've never seen a camera that killed batteries that fast. Are they hot or warm when you take them out of the camera?
    Is anything visible when you take a look into the battery chamber? Piece of wire? chewing gum wrapper? 15A fuse?
     
  5. agfarapid

    agfarapid Subscriber

    Messages:
    191
    Joined:
    Nov 21, 2008
    Location:
    New England
    Shooter:
    Multi Format
    They're not even warm when I remove them. Very strange...I put in a set of rechargeable Ni Mh a about 6 hours ago and they are still holding the charge. I also played with the battery holder--it seems that its slightly bent (although I can't see why that would drain fresh batteries). When I pressed the holder in, it seemed to make better contact. Thanks for all the help..I'll keep you guys posted.
     
  6. gupa

    gupa Member

    Messages:
    20
    Joined:
    May 5, 2009
    Shooter:
    35mm
    Are you sure the batteries are really dead? Maybe there is an intermittent power problem due to a poor connection in the battery holder. You could remove the batteries then reinstall the same ones to check that out.
     
  7. agfarapid

    agfarapid Subscriber

    Messages:
    191
    Joined:
    Nov 21, 2008
    Location:
    New England
    Shooter:
    Multi Format
    Just to put closure on this thread, I switched to rechargeable Ni Hd and also fiddled with the battery holder which seems to have done the trick. I'll probably have to get a new battery holder because the connection seems a bit loose when inserted into the F100 body. Thanks for all the help & support.