Nikon F3 - 1 second in manual mode not working?

Discussion in '35mm Cameras and Accessories' started by IloveTLRs, Mar 9, 2012.

  1. IloveTLRs

    IloveTLRs Member

    Messages:
    1,117
    Joined:
    May 22, 2007
    Location:
    Boston
    Shooter:
    Sub 35mm
    Hello,

    I was given an F3 today, and I've been trying to fix it up (it's been sitting somewhere for 20-odd years.)
    One thing that troubles me, is 1 sec doesn't fire correctly in manual mode- it's more like 1/8-ish. All the speeds above and below it are fine in both modes. In A mode, 1 second is fine. I have working batteries inside.

    That isn't normal is it? :pouty:

    Also, should I not expect the LCD illuminator to work 100%? It's a bit dim and takes a hard button push to work.
     
  2. BrianShaw

    BrianShaw Member

    Messages:
    6,658
    Joined:
    Nov 30, 2005
    Location:
    Los Angeles,
    Shooter:
    Multi Format
    1 second should be 1 second shutter duration when the shutter speed dial is set to 1... providing your batteries are good and the swich is turned to the on position.

    The "illuminator" is not one of the better features of the F3. Even when new it was a hard button to push and only dimly illuminated the LCD.
     
  3. IloveTLRs

    IloveTLRs Member

    Messages:
    1,117
    Joined:
    May 22, 2007
    Location:
    Boston
    Shooter:
    Sub 35mm
    Thank you! I actually did a bit of reading and found out about the illuminator, but thank you!

    As for 1 second, it only works in A mode for some reason still. The rest of the camera seems okay, so I will just be using it. I can hardly complain about a free camera.
     
  4. CGW

    CGW Member

    Messages:
    2,797
    Joined:
    Apr 19, 2010
    Shooter:
    Medium Format
    They were arguably one of Nikon's greatest. They also had the ability to meter in A mode insanely long exposures--great for night shots.