Nikon F4, Film loading/advance problem

Discussion in '35mm Cameras and Accessories' started by zanxion72, Oct 19, 2013.

  1. zanxion72

    zanxion72 Member

    Messages:
    280
    Joined:
    Oct 18, 2013
    Location:
    Athens
    Shooter:
    Multi Format
    Dear All,
    My Nikon F4 recently had developed a strange fault. When trying to load film, upon first shot the film advances to the first frame and then the red led comes on. After waiting for a while pressing the shutter button again it moves the film as if trying to load it and then halts with a red led again. The batteries are fresh.
    Do you know why this has happened all of a sudden? Is it something that can be repaired by me? If not, is it worth repairing it, or buying another body?

    Many thanks in advance for your advice.
     
  2. John_Nikon_F

    John_Nikon_F Subscriber

    Messages:
    1,918
    Joined:
    Apr 18, 2008
    Location:
    Duvall, WA,
    Shooter:
    35mm
    The R2 lever is in its normal position, right? If not, reset it and try again. If it is, then I'm guessing there's an issue with the sensor that tells the camera that your film is ready to be loaded. Unless the camera is really nice cosmetically, it's probably going to be a better idea to grab another body, then tear this one down for parts. An overhaul can run upwards of $300. Nice F4 bodies can be had for half that from time to time. My previous F4s was one that I bought for $143.50, plus shipping. Was almost mint, cosmetically. Even had the cap on the cable release socket and was a fairly late model, being in the 2516xxx serial range.

    -J
     
  3. Ricardo Miranda

    Ricardo Miranda Member

    Messages:
    2,083
    Joined:
    Mar 31, 2012
    Location:
    London, UK
    Shooter:
    35mm
    In the UK, it is only £100 for a CLA by a Nikon authorised repairer. Send it to: http://www.aztechservices.com
     
  4. zanxion72

    zanxion72 Member

    Messages:
    280
    Joined:
    Oct 18, 2013
    Location:
    Athens
    Shooter:
    Multi Format
    I had no response from them so far. Anyway, I have bought another one. I will find somebody to repair it though, no matter what.