Nikon FM2/FE2 meter problems...

Discussion in '35mm Cameras and Accessories' started by Uri, Mar 23, 2011.

  1. Uri

    Uri Member

    Messages:
    2
    Joined:
    Sep 2, 2009
    Location:
    Sydney, Aust
    Shooter:
    Plastic Cameras
    Hi all,

    I have an FM2 that has never missed a beat since i bought it 20 yrs ago. Also I just bought an FE2 off ebay in practically mint condition and just this week BOTH of them have started up with the EXACT same problem: the meter functions intermittently.
    FYI:
    1. the batteries are brand new energizers out of the packet (I have tried several sets from different shops).
    2. there is no visible corrosion in the contacts or chamber (i cleaned them anyway)
    Sometimes all is well and working, and then ... suddenly: dead. just when I think I am losing my mind - they work again!
    Anyone had this problem and know a solution?? can I dismantle/clean/fix this myself somehow?
    Thanks in advance for your help!
     
  2. John_Nikon_F

    John_Nikon_F Subscriber

    Messages:
    1,721
    Joined:
    Apr 18, 2008
    Location:
    Duvall, WA,
    Shooter:
    35mm
    Could be that both cameras have wiring issues under the baseplate, or the microswitch on the shutter release button isn't operating consistently. My last FM2n did at first have issues with the meter turning on. Had to hit it twice, then it came on. Am currently bidding on one that has a supposedly dead meter. As in, completely dead. Essentially is a Nikkormat FS with a smaller body, motor drive coupling, and faster shutter speeds. Will be interesting to see what I discover, if I get it...

    -J
     
  3. fstop

    fstop Member

    Messages:
    724
    Joined:
    Apr 4, 2011
    Shooter:
    35mm
    ah, the joys of ebay roulette...

    Could be the contacts inside,at the on switch and the switch on the shutter release.

    Make sure the threads on the cap and chamber are clean too

    I've been battling a FA with the same sort of problem.