NPC back for Hasselblad Film Jam

Discussion in 'Instant Cameras, Backs and Film' started by steveb533, Aug 2, 2011.

  1. steveb533

    steveb533 Member

    Messages:
    23
    Joined:
    Jul 22, 2009
    Location:
    Arlington, V
    Shooter:
    Medium Format
    I have been having trouble with my NPC back I bought for my Hasselblad. When I try to pull on the white leader, after exposing a frame, it comes off, but the actual film which has the black leader is jammed inside the back. I have gone through two packs of Fuji FP100 C film.
    Does anyone know if there are different size NPC backs for Hasselblad cameras? Mine just says NPC on it, no model #. Its black, btw. I cleaned the roller too.
    Thanks in advance
    Steve
     
  2. jeffreyg

    jeffreyg Subscriber

    Messages:
    1,336
    Joined:
    Jun 12, 2008
    Location:
    florida
    Shooter:
    Medium Format
    I have a Hasselblad magazine 100 for Polaroid film. I have not had the problem you describe. It does say Hasselblad on the actual back. I haven't used it with Fuji 100 film though. It may be that the Fuji film packs are of a different configuration. If no one here has more accurate information you might try calling KEH or Calumet and get an answer. I would be interested in knowing as well before buying the Fuji film. Keep us posted -- thanks.

    http://www.jeffreyglasser.com/
     
  3. AlexCave

    AlexCave Member

    Messages:
    3
    Joined:
    Jul 28, 2011
    Shooter:
    Medium Format
    I have the same back and I've had the same thing happen before but after a few packs, it started working again. Sometimes the black leader with the film folds up like an accordion, but after taking it in the darkroom and holding the leader flat, it would work again. I've had similar problems with other backs too, like my polaroid passport camera.
     
  4. steveb533

    steveb533 Member

    Messages:
    23
    Joined:
    Jul 22, 2009
    Location:
    Arlington, V
    Shooter:
    Medium Format
    Does anyone else have any input? It feels like the film with the black leader is not even close to coming out. I thought I had read somewhere that there were two different NPC backs and one took 105 film possibly. Thanks
    Steve
     
  5. Leigh B

    Leigh B Member

    Messages:
    1,035
    Joined:
    Jan 17, 2011
    Location:
    Maryland, US
    Shooter:
    Multi Format
    I don't know if the NPC back is compatible with Fuji film.

    For example, the Polaroid 545i back is, but the original 545 is not.

    Since the NPC back was available quite early on, it's probably based on the 545.

    I don't know what the difference is. I ran across this information while researching the Fuji pack film.

    - Leigh
     
  6. xya

    xya Member

    Messages:
    283
    Joined:
    Jun 13, 2010
    Location:
    Calais, Köln
    Shooter:
    Multi Format
    the 545 is for single sheet film. this has nothing to do with pack film. the fuji packs have exactly the size of the old polaroid packs. if the pack slips in, it fits. the only difference is that fuji has 10 film in one pack, the old polaroid had only 8. which makes the pack well packed. so for certain backs it's difficult to tear the black shield and sometimes the first film. after this it's like the old polaroid packs.

    are you shure that you put the pack and the white tabs the way it should be? there are plenty of videos on the web which show you how to do. I've seen people trying to get the black slip between the rollers (not that I presume that you did). the white tabs are so important. if the rollers are clean and one of it moves easily, the yellow tab should appear after you have pulled the white tab. and then by pulling the yellow tab straight out of the back it should work.

    kind regards
     
  7. Leigh B

    Leigh B Member

    Messages:
    1,035
    Joined:
    Jan 17, 2011
    Location:
    Maryland, US
    Shooter:
    Multi Format
    Yep, 'tis for single sheets. I wasn't thinking. Thanks.

    - Leigh
     
  8. steveb533

    steveb533 Member

    Messages:
    23
    Joined:
    Jul 22, 2009
    Location:
    Arlington, V
    Shooter:
    Medium Format
    Xya, thanks to your reassurance about it fitting, I tried a third pack and it is working now. I guess I hadn't cleaned the rollers enough. Maybe it needed a few packs to go through it in order to clean it out. Thanks for everyone's input on this.
    Steve