npc back problem

Discussion in 'Medium Format Cameras and Accessories' started by dxphoto, Dec 7, 2005.

  1. dxphoto

    dxphoto Member

    Messages:
    196
    Joined:
    Nov 25, 2005
    Shooter:
    35mm
    Hi,

    I got a NPC back for my bronica etrs. When I tried the film pack, every time I pull the film out, the jell came out too. the jell on the spool moisturized the tab so i could not pull the next sheet out. Did i do anything wrong? or the back is broken. thanks.
     
  2. David A. Goldfarb

    David A. Goldfarb Moderator Staff Member Moderator

    Messages:
    18,123
    Joined:
    Sep 7, 2002
    Location:
    Honolulu, Ha
    Shooter:
    Large Format
    Sometimes that happens. Do you clean the rollers occasionally? It's a good idea at least to check them between packs. Check the instructions at the Polaroid site. Most Polaroid backs work the same way in this respect. The only differences are the mounting plate, and in the case of the 35mm NPC and Forscher backs, the fiber optic block. I believe the Hassy Polaroid back also has a glass plate to improve focus, but that's not relevant to the problem you're having.
     
  3. Changeling1

    Changeling1 Member

    Messages:
    659
    Joined:
    Mar 19, 2005
    Location:
    Southern Cal
    Shooter:
    4x5 Format
    NPC easy to deal with

    You can always call or email NPC http://www.npcphoto.com/ with any questions or problems with any of their products. They helped me out with my 15 year old GS-1 NPC back and were more than happy to help.
     
  4. Photo Engineer

    Photo Engineer Subscriber

    Messages:
    26,673
    Joined:
    Apr 19, 2005
    Location:
    Rochester, NY
    Shooter:
    Multi Format
    The last time that happened to me, I called Polaroid. I explained the problem, and they asked me for the # on the back of the prints. When I gave it to them, they told me to throw away the rest of the pack as it was defective and they sent me a voucher for a new 2 pack at the local store.

    PE
     
  5. Dave Parker

    Dave Parker Inactive

    Messages:
    4,049
    Joined:
    Aug 14, 2004
    Shooter:
    Multi Format
    I am with PE on this one, a couple of years ago, I had a simular problem with and NPC back and it was due to older defective film packs, Polaroid sent me vouchers and told me to get rid of them..

    Also as David said, make sure the rollers are clean with no residue, I have had this cause problems with my pack backs as well.

    Dave