olympus xa2 sticky shutter release button.

Discussion in '35mm Cameras and Accessories' started by Alan W, Sep 12, 2010.

  1. Alan W

    Alan W Subscriber

    Messages:
    455
    Joined:
    May 16, 2009
    Location:
    Tennessee
    Shooter:
    Medium Format
    That's it basically,sometimes it works,sometimes it doesn't.I wondered if anyone else has this problem and what the solution is?Thanks as always,Alan.
     
  2. wblynch

    wblynch Member

    Messages:
    1,646
    Joined:
    Feb 9, 2009
    Location:
    Mission Viejo
    Shooter:
    127 Format
    I have that problem on one of my XA's. You have to press really hard and don't always get what you want...

    Waiting for suggestions.
     
  3. Jon Shiu

    Jon Shiu Subscriber

    Messages:
    2,812
    Joined:
    Dec 2, 2003
    Location:
    Elk, Califor
    Shooter:
    Plastic Cameras
    On mine, sometimes it will work after you jiggle the film advancing winder back and forth.

    Jon
     
  4. benjiboy

    benjiboy Subscriber

    Messages:
    8,604
    Joined:
    Apr 18, 2005
    Location:
    U.K.
    Shooter:
    Multi Format
    I suggest you have it serviced, what could be a disaster if you try and fix it youself could be half an hours work for a trained camera mechanic, and not as expensive as you think.
     
  5. bobwysiwyg

    bobwysiwyg Subscriber

    Messages:
    1,622
    Joined:
    Mar 28, 2008
    Location:
    Ann Arbor, M
    Shooter:
    Multi Format
    Mine did this as well. I finally figured out it seems to be related to the film advance wheel. If you don't fully, and firmly advance all the way, it seems to cause this problem. Perhaps there is some sensitive contact that is engaged at the end of the advance procedure???
     
  6. John Hermanson

    John Hermanson Member

    Messages:
    306
    Joined:
    Sep 19, 2005
    Location:
    Huntington,
    Shooter:
    35mm
    Could be weak dirty batteries, dirty battery cap (edge of cap must be clean too). Sliding cover switch, release button, dirty 2nd magnet. John
     
  7. BetterSense

    BetterSense Member

    Messages:
    3,126
    Joined:
    Aug 16, 2008
    Location:
    North Caroli
    Shooter:
    35mm
    MY XA2 would occasionally make a gross overexposure. Is this something to do with the shutter magnets?
     
  8. John Hermanson

    John Hermanson Member

    Messages:
    306
    Joined:
    Sep 19, 2005
    Location:
    Huntington,
    Shooter:
    35mm
    If magnet were dirty, camera would tend to overexpose on every shot. John