Problem with De Vere 5x7 closed-loop colour head

Discussion in 'Enlarging' started by conorbc, Nov 22, 2009.

  1. conorbc

    conorbc Member

    Messages:
    3
    Joined:
    Mar 13, 2009
    Location:
    Ireland
    Shooter:
    Medium Format
    Hi everyone,

    This is my first post on APUG and I'm hopeful that someone will have answers to my questions since I've seen the collective wisdom that's out there.

    I recently bought a second-hand De Vere 507 enlarger with the closed-loop colour head and installed it in a shed that I've been converting into a darkroom over the past while. It worked very well initially but I think that it has succumbed to the dampness in Ireland because when I switched it on recently, there was a bit of buzzing and flashing from within the head and, since then, it's no longer working properly. The two lamps are still lighting but the internal shutter doesn't open any longer and the filters seem to be parked rather than moving when adjusted from the remote keypad. The message on the keypad is that the lamps are blown but I think that the sensor is simply not seeing the light, so to speak, since the shutter and filters are seized.

    My questions concern repair of the head. Is it an operation that one could consider doing oneself or is it a job for a pro? Should I try to get it fixed by an electronics handyman or just bite the bullet and send it to Odyssey in the UK? Have any of you had similar experience with the closed-loop head? Perhaps I should give up on this head as being too complicated? I shoot B&W only, up to 5x4. Can more commonly available 5x4 heads be fitted to this enlarger?

    Lots of questions so thanks in advance,

    Conor.
     
  2. Bob Carnie

    Bob Carnie Subscriber

    Messages:
    5,478
    Joined:
    Apr 18, 2004
    Location:
    Toronto-Onta
    Shooter:
    Med. Format RF
    Send it to a pro.
     
  3. Mark Antony

    Mark Antony Member

    Messages:
    790
    Joined:
    Mar 27, 2007
    Location:
    East Anglia,
    Shooter:
    Multi Format
    I'd give the guys from odyssey a call, they'll give you advice on what may have happened and if it can be self fixed and how to avoid it happening again.
    http://www.odyssey-sales.com/
    01273 676768
     
  4. jvo

    jvo Subscriber

    Messages:
    470
    Joined:
    Dec 6, 2008
    Location:
    left coast of east coast
    Shooter:
    Medium Format
    friend had one

    a friend had a devere... liked it and found it reliable. he remarked one time, that if anything ever went wrong with it, you gotta have someone who knows what they're doing repair it - because of the electronics!
     
  5. conorbc

    conorbc Member

    Messages:
    3
    Joined:
    Mar 13, 2009
    Location:
    Ireland
    Shooter:
    Medium Format
    Thanks,

    I called Odyssey who said that I should send the head to them and that only once they looked at it could they tell me how much repair would cost. However, they did mention that a 5x4 head can be used on the 5x7 chassis, so I might look at that as a cheaper and more robust solution than getting the closed loop head repaired.

    Conor.