problem with olympus xa

Discussion in 'Rangefinder Forum' started by pquser, Apr 8, 2008.

  1. pquser

    pquser Member

    Messages:
    50
    Joined:
    Feb 13, 2008
    Location:
    Rochdale , l
    Shooter:
    35mm
    Love this little camera to bits but just noticed today that the shutter speed
    display has stopped working.

    The shutter still works properly and exposure is still corect it's just that the
    needle in the viewfinder seems to be ''stuck''

    both batteries checked and are ok for voltage.

    Anyone else had this ?

    pquser.

    Bob.rochdale uk
     
  2. Peter Black

    Peter Black Subscriber

    Messages:
    1,001
    Joined:
    Mar 19, 2005
    Location:
    Scotland, UK
    Shooter:
    Multi Format
    I've had this or a similar problem with the meter, but you're correct in saying that it just keeps working anyway. My one is sufficiently old that it is past repairing and I don't use it that often anyway, but exposure still seems pretty accurate and Ilford XP2 would be printable even if it was a couple of stops out. You'll need the batteries for the shutter release as well as the meter. I'd just live with it!
     
  3. Mark Fisher

    Mark Fisher Subscriber

    Messages:
    1,672
    Joined:
    Dec 13, 2003
    Location:
    Chicago
    Shooter:
    Medium Format
    I've had that happen before too. Since the XA is handholdable at very slow shutter speeds, I never found it to be a problem....then I lost it and had to buy another one :smile:
     
  4. manfromh

    manfromh Member

    Messages:
    118
    Joined:
    May 22, 2007
    Location:
    Tallinn, Est
    Shooter:
    35mm
    I read somewhere that the XA actualy has two lightmeters. One for the shutter and other for the needle in the viewfinder. If so, then I guess just the needle meter isn't working.
     
  5. pquser

    pquser Member

    Messages:
    50
    Joined:
    Feb 13, 2008
    Location:
    Rochdale , l
    Shooter:
    35mm
    Hi everyone....good news

    the camera just fixed itself !!

    thanks for your commets.

    pquser
     
  6. Steve Smith

    Steve Smith Subscriber

    Messages:
    8,970
    Joined:
    May 3, 2006
    Location:
    Ryde, Isle o
    Shooter:
    Medium Format
    I have a problem with my XA at the moment too. I can't find it!


    I have noticed that they can become a bit 'quirky' if the battery contacts are not perfectly clean.


    Steve.