Problems unloading the film on Kiev-19

Discussion in 'Camera Building, Repairs & Modification' started by andremartins, Feb 12, 2011.

  1. andremartins

    andremartins Member

    Feb 12, 2011

    so, i've got this problem: i can't open the back part of the camera (where you load the film)...

    So, the context of this problem is: i bought the Kiev-19 from eBay, and when i received it, i started "taking" pictures right away, because i thought there was a film already installed in the camera... i thought this because everything seemed to point to that fact (espeacially because the picture counter kept going, eveytime i "took" a photo)
    So, when the counter gets to the 36th photo, and i thought that the film had ended, i tried to unload the film... i clicked in the tape transport mechanism release button, so that the back would open... but it didn't! i took some more photos and the counter was still in the 36th photo. i realized "oh well, there's no film inside!"

    that was already disturbing enough, but then i tried "to move on" and focus on opening the back, putting a new film and forget about the 36 pictures i had already "taken"... but, the thing is that now i can't open the back... i keep clicking on the button, i keep pushing the back, and i can't get it open...

    can someone tell me how to do so?
    i suspect something got locked inside the camera, due to the fact of me being "taking" pictures without a film inside...
  2. Anscojohn

    Anscojohn Subscriber

    Dec 31, 2006
    Medium Format
    The frame counter advances whether or not there is film in the camera. The back opens by pulling up on the rewind knob on the left side of the camera.