Problems with my M645J

Discussion in 'Medium Format Cameras and Accessories' started by swittmann, Jan 25, 2013.

  1. swittmann

    swittmann Member

    Messages:
    199
    Joined:
    Jan 23, 2010
    Location:
    Berlin, Germ
    Shooter:
    Medium Format
    Dear all,

    I have a Mamiya M645J, which gave me several problems lately and I am not sure whether it's a light leak or a problem with the shutter curtains - or maybe sth else. Any ideas?

    (The problem occurred with the last 2 films. At the first film of these two, it was just one picture; at the 2nd film, it happened several times. I haven't used the camera since.)

    Your help is much appreciated - thank you very much in advance.
     

    Attached Files:

  2. wblynch

    wblynch Member

    Messages:
    1,646
    Joined:
    Feb 9, 2009
    Location:
    Mission Viejo
    Shooter:
    127 Format
    This is a common problem but I don't know the cause. It is a shutter fault. I am hoping a comprehensive answer will be presented.

    In the meantime you might try a fresh battery.
     
  3. swittmann

    swittmann Member

    Messages:
    199
    Joined:
    Jan 23, 2010
    Location:
    Berlin, Germ
    Shooter:
    Medium Format
    Thank you, Bill. I will follow your advice to change the battery and let you know if it helped.
     
  4. mr rusty

    mr rusty Member

    Messages:
    758
    Joined:
    Sep 7, 2009
    Location:
    lancashire,
    Shooter:
    Medium Format
    No its not.

    It's light leaking in around the catch for the back door. This exposes a strip of the film exactly as shown. I know this because I had exactly the same. I replaced the back door foams on my new-to-me M645J and stopped the foam strips just either side of the catch, figuring the bit of metal on the back door over the catch mechanism was a light trap - wrong!. First film I shot was OK - prob because I shot it over a short period of time in subdued light. Next film I was carrying the camera around in sunlight and ended up with exactly this strip across the neg. I bet if you look at the neg itself the dark stripe extends beyond the exposed area to the edge of the film. I re-made the seal making sure the foam was continuous around the catch. Get your seals sorted and all will be good.

    lightleak.jpg

    quick scan of top of offending neg

    Light seal kit here http://www.ebay.co.uk/itm/LIGHT-SEA...t_Parts_Tools_Repair_Kits&hash=item589ac410c8

    Good tip when using self-adhesive foam - wet the surface of the sticky surface with a small amount of water with some wetting agent - detergent or photo flo - you don't need much. The self adhesive foam doesn't stick at first and you can easily slide it about. leave it to dry and the foam is then stuck properly. Trying to do mirror foams, where you have some awkward positioning, without knowing this trick is almost impossible because dry, the foam sticks straight away and you can't reposition it
     
    Last edited by a moderator: Jan 26, 2013
  5. swittmann

    swittmann Member

    Messages:
    199
    Joined:
    Jan 23, 2010
    Location:
    Berlin, Germ
    Shooter:
    Medium Format
    Wow, thank you, Mr Rusty! Yes, it does extend indeed.

    Thank you for the great tip re: using wetting agent and also for the link.

    I already changed the light seals of my Hasselblad a while ago, but its light leaks looked totally different, that's why my first thought was that I have 'shutter problems' this time.

    So, thank you again, Bill and Mr Rusty.
     
  6. mr rusty

    mr rusty Member

    Messages:
    758
    Joined:
    Sep 7, 2009
    Location:
    lancashire,
    Shooter:
    Medium Format
    pleased to be of help :smile: