Problems with Super Baldax

Discussion in 'Medium Format Cameras and Accessories' started by Poohblah, Apr 17, 2009.

  1. Poohblah

    Poohblah Member

    Messages:
    433
    Joined:
    Aug 30, 2008
    Shooter:
    Multi Format
    Hi guys,
    I just received a Super Baldax from Jurgen (cue groan) and I have a couple issues. First, the winding mechanism is being VERY finicky. I put one roll through the camera already and I only got 8 or 9 shots out of 12 because the winding mechanism sometimes wouldn't allow the shutter to trip even though I had wound on to the next frame. This is a known issue AFAIK. Secondly, the shutter sticks occasionally on the faster speeds. It didn't happen on my first roll, luckily, but it did happen when I was testing the camera without film. Finally, it definitely does not look like Jurgen did a CLA as he said he did.

    So I guess basically what I'm getting at is: Should I send out for a CLA, and if so, who? Keep in mind that I am a student and I sold some 35mm equipment that I don't use any more to buy this camera, so I have very little cash.
     
  2. Samuel Hotton

    Samuel Hotton Member

    Messages:
    358
    Joined:
    Jul 4, 2005
    Shooter:
    Medium Format
    I would write to Jurgen and explain your cameras problems. He has a good warranty and does honor it.
    Sam H.
     
  3. jnanian

    jnanian Advertiser Advertiser

    Messages:
    20,097
    Joined:
    Jun 21, 2003
    Location:
    local
    Shooter:
    Multi Format
    i would ship the camera back and demand a full refund, including shipping 2 ways.

    i sent a camera to him to be repaired ... i was embarrassed to receive it in the condition he sent it to me
    ... embarrassed for him.

    he hacked mine up something awful - welded things that didn't need to be welded, shoved things back together poorly ...
    then, after waiting a long 30 days and a handful of cash later it broke the first day i had it, the first time i used it. :sad:
    i did manage to speak with him about my misfortune on the telephone, and
    he admitted that it looked terrible the way he sent it back to me, and he would be happy to fix it again
    at no cost ( except for shipping charges) .. seeing how he "fixed it" the first time i saw no reason
    to put my poor camera through that kind of meatball surgery again.

    eventually, i found / bought a parts-hog for my own repairs, i realized the one i sent him only needed a screw ...
    and this made me pretty mad.

    i know others have had no problems with him, and swear by his work ..
    but there is a growing number of folks who will never buy something from him,
    or send him anything to repair.

    good luck!
     
    Last edited by a moderator: Apr 19, 2009
  4. Andrew Moxom

    Andrew Moxom Member

    Messages:
    4,886
    Joined:
    Feb 2, 2007
    Location:
    Keeping the
    Shooter:
    Multi Format
    I have a Super Baldax that was CLA'd from Juergen. The camera went out needing a new leaf in the shutter as one had torn and jammed, and the leather glued back on, and a focus check. It came back with a broken rangefinder window (common on repair apparently!) and the shutter that was transplanted from another camera needed to go back as the shutter speed dial was soooo tight the whole lens and shutter rotated in the mount when you moved it!! The leather was not completely glued back. I sent it back as I could not prove the RF glass was done by him, yet he made the shutter work right. That said, it really was a turd of a camera to start with and completely misrepresented by the famous source in England that sells these from time to time on Fee'bay. IT works and looks fine now after some TLC myself. Juergen has a 6 month warranty on his work. I might not use him again though as I think there is some ham fistedness in the approach to CLA... YMMV.
     
  5. nemo999

    nemo999 Member

    Messages:
    279
    Joined:
    Jul 20, 2008
    Shooter:
    35mm
    And bear in mind that doing a CLA on a leaf shutter is (or should be) a totally routine operation with a perfect result every time for someone who knows what they are doing.
     
  6. Poohblah

    Poohblah Member

    Messages:
    433
    Joined:
    Aug 30, 2008
    Shooter:
    Multi Format
    Thanks for the sympathy guys, but I'm not sending my camera back to Jurgen. Not while I have it in my hands :D

    From some postings over on RFF, it seems that this is part user error at least. I think I'll send the camera to Essex if it keeps up the misbehavior.
     
  7. Galah

    Galah Member

    Messages:
    481
    Joined:
    Feb 4, 2009
    Location:
    Oz
    Shooter:
    Multi Format
    I had similar problems with my Voigtlander Vito II (check out this link: http://www.apug.org/forums/forum65/59880-vito-ii-troubles-help-please.html )

    I had a sticking shutter at low speeds. When it came back from the CLA, it had developed shutter stick at high speeds and an erratic shutter release action as well as "interlock" problems (i.e., just like in your case, the shutter would be able to trip when it shouldn't, allowing multiple exposures etc. and refuse to trip when it should, missing shots). Consequently, I lost a couple of films and had to send the camera back (a total of three or four trips -in all- to the service dept.)

    Well, the truth is, it is like an old car: repair one thing and the next thing breaks :smile: !

    Anyway, both I and the serviceman persevered, and one or two springs and a lot of sweating later, it now appears to be working very well :smile: : although I have still to finish off the test film and have it processed.

    In my case, the total cost was under Aus$35-00, as the repairman wanted to stand by his workmanship. (I did offer to pay the difference, but he wouldn't hear of it).