Ricoh KR-5 shutter not opening... :(

Discussion in '35mm Cameras and Accessories' started by WorldFamousBigB, May 10, 2009.

  1. WorldFamousBigB

    WorldFamousBigB Member

    Messages:
    3
    Joined:
    May 7, 2009
    Shooter:
    35mm
    Hello everyone,
    my Ricoh KR-5 was working fine until this afternoon when I tried to take a picture; the shutter button would press down, but nothing happened. I checked to see if I had forgotten to advance to film, but it was already advanced. I ended up having to cut this roll of pictures short so that I could look inside to see if something was blocking the shutter, but I couldn't see anything. The inside looks pretty normal to me.
    So, the shutter won't open, and I can't advance any film that I put into the camera.
    Has anyone ever encountered a similar problem to mine? If so, were you able to fix the issue?

    Thanks for any advice,

    Alex
     
  2. ben-s

    ben-s Member

    Messages:
    443
    Joined:
    Jul 12, 2006
    Location:
    Nottingham,
    Shooter:
    Multi Format
    Have you checked the battery?
    I've got a KR-10, which won't fire without a battery installed, so your KR-5 might be the same...
     
  3. WorldFamousBigB

    WorldFamousBigB Member

    Messages:
    3
    Joined:
    May 7, 2009
    Shooter:
    35mm
    I'm pretty sure it's not the battery. The batteries are brand new this week, and I was able to play around with the shutter before I had put batteries in.
    Thanks for the suggestion though.
     
  4. ben-s

    ben-s Member

    Messages:
    443
    Joined:
    Jul 12, 2006
    Location:
    Nottingham,
    Shooter:
    Multi Format
    Ah... sounds like it's a mechanical problem rather than an electrical oddity then.
    Hope you can get it sorted out soon.