shutter not firing on a fuji gw690iii

Discussion in 'Medium Format Cameras and Accessories' started by darinwc, Feb 18, 2012.

  1. darinwc

    darinwc Subscriber

    Messages:
    2,466
    Joined:
    Dec 14, 2003
    Location:
    Sacramento,
    Shooter:
    Multi Format
    i just received a very nice looking fuji gw690iii
    However it has 2 problems..
    1 the shutter will not fire
    2 the rangefinder does not appear to be working.

    Are these normal for this camera that I have to toggle a switch or load a battery or is it just broken?
    THX
     
  2. keithwms

    keithwms Member

    Messages:
    6,070
    Joined:
    Oct 14, 2006
    Location:
    Charlottesvi
    Shooter:
    Multi Format
    Has it ever worked for you? Or did it arrive that way? How did you test it?
     
  3. dnjl

    dnjl Member

    Messages:
    376
    Joined:
    Sep 19, 2010
    Location:
    Switzerland
    Shooter:
    35mm
    You probably know this, but the cocking lever needs to be moved twice. If you can't press the shutter release button down, then there's your problem. If you can push it down but nothing happens, the shutter may indeed be broken.

    Fuji GWs seem to have some problems with drying lubricant in the rangefinder mechanism. When mine arrived, the rangefinder didn't work either. It suddenly started working after 30min of focusing around and has been functioning excellent ever since. Maybe this works for you too, I don't know.

    Good luck, they're awesome cameras.
     
  4. Dan Daniel

    Dan Daniel Subscriber

    Messages:
    784
    Joined:
    Jul 4, 2009
    Shooter:
    Medium Format
    On at least the first GW690, the back must be open for you to fire the shutter without film. try unlatching the back?

    As to the rangefinder not working, that is not a good sign. I hope it loosens up or such.

    The camera is all mechanical. No batteries, no fancy switches.
     
  5. darinwc

    darinwc Subscriber

    Messages:
    2,466
    Joined:
    Dec 14, 2003
    Location:
    Sacramento,
    Shooter:
    Multi Format
    for number 1: the shutter not firing.. RTFM. It will not fire unless there is film in the camera or you can open the rear door.

    for number 2: the rangefinder not working. Thank you Walt. With the back open, I could see the linkage between the lens and the rangefinder. There was a pin from the camera body and it was stuck in.
    I fiddled with it for a few minutes and then it popped out. Then i cleaned it with a swab and then applied a thin watch oil. Now it seems to be working fine. Yay!