Sticky aperture ring on 300 2.8 EDIF AIS

Discussion in '35mm Cameras and Accessories' started by jbear, Dec 1, 2004.

  1. jbear

    jbear Member

    Messages:
    6
    Joined:
    Dec 11, 2003
    Well, I received my 300 f2.8 AIS today, and for $500, I am pretty thrilled! The glass is absolutely spotless (and no dust inside). The diaphragm is pretty snappy and the focusing is very smooth. The body is definitely used, but overall in good shape. The only thing I have noticed is that the aperture ring is a bit "sticky." If I squeeze at all while trying to turn it it doesn't want to go. If I use a light touch it is fine. What do you think? Something I can remedy at home? Something to just live with? A CLA?
    Question 2 while I have your attention, do you know where can I get a "leather" hood for this lens? How about a 122mm protective filter? Thanks for any insight in advance.
    I sure am excited about getting out and shooting with it this weekend!
     
  2. John Koehrer

    John Koehrer Subscriber

    Messages:
    6,420
    Joined:
    Apr 3, 2004
    Location:
    Montgomery,
    Shooter:
    Multi Format
    it may be slightly out lf round(bent) it doesn't take much to ding 'em. that pressure on ring is a clue.
    If you're lucky it may just need cla.
    ebay for the cap, there's an article in"restoring classic & collectible cameras" by thamoa tomosy on building custom lens caps from scratch.
    I've made several for old lenses. it takes a little time. but less time than searching for the original.
     
  3. John Koehrer

    John Koehrer Subscriber

    Messages:
    6,420
    Joined:
    Apr 3, 2004
    Location:
    Montgomery,
    Shooter:
    Multi Format
    thomas tomosy not "thamoa"