Sticky MU on Mamiya RZ Lens

Discussion in 'Medium Format Cameras and Accessories' started by dancqu, Sep 24, 2007.

  1. dancqu

    dancqu Member

    Messages:
    3,676
    Joined:
    Sep 7, 2002
    Location:
    Willamette V
    Shooter:
    Medium Format
    The camera and lens can only be used in mirror up mode.
    The lens' cable attachment does not return with removal of
    the cable release. No big deal as I always shoot with a cable
    but as it is the cable must be attached to the lens. If detached
    the camera shutter closes after the 60 second limit has been
    reached. Might a half drop of light oil fix the problem?
    Or is oil a no-no with camera gear? Dan
     
  2. konakoa

    konakoa Member

    Messages:
    161
    Joined:
    Sep 23, 2006
    Shooter:
    Large Format
    Sometimes the little collar with the red ring on the lens for the mirror lockup sticks. Have you tried screwing in the cable release and then unscrewing it? When mine do this I've found that re-attaching, then slowly unscrewing the cable release will let the collar retract.
     
  3. dancqu

    dancqu Member

    Messages:
    3,676
    Joined:
    Sep 7, 2002
    Location:
    Willamette V
    Shooter:
    Medium Format
    ...just about every which way? Have done that.
    That half drop of oil is my last hope. Dan
     
  4. benjiboy

    benjiboy Subscriber

    Messages:
    8,598
    Joined:
    Apr 18, 2005
    Location:
    U.K.
    Shooter:
    Multi Format
    Don't try to oil it, take it to a camera repairer, and have it serviced by someone who knows what he's doing, camera lubricants are special oils, and it would be foolish for you to do so in my opinion.
     
    Last edited by a moderator: Sep 26, 2007
  5. max_ebb

    max_ebb Member

    Messages:
    232
    Joined:
    Nov 2, 2006
    Shooter:
    Medium Format
    I just recently had the same thing happen with a K/L lens the first time I used it. What I finally did to get it to go back in was screw the cable release in really tight (tighter than I would for normal use), and then it twisted back down when I unscrewed the cable. Now it works fine with normal attaching and removal of the cable release.