Sudden Zone VI Stabilizer Buzz!

Discussion in 'Darkroom Equipment' started by RidingWaves, May 26, 2011.

  1. RidingWaves

    RidingWaves Member

    Messages:
    824
    Joined:
    Feb 22, 2006
    Location:
    Hawaii
    Shooter:
    35mm RF
    Hey, my Zone VI cold light stabilizer just started buzzing. After taking notes as to the settings, I was able to stop the buzzing by adjusting the unit, but at useful settings the buzzing returned. At my most used settings it looks as if the light has a flicker. Any ideas what's going on? I've had and used this unit for at least 12 years consistently.
     
  2. ChuckP

    ChuckP Subscriber

    Messages:
    655
    Joined:
    Jan 8, 2003
    Location:
    NW Chicagola
    Shooter:
    Multi Format
    The stabilizer is buzzing or the cold light? Does the light work Ok when you plug it in direct to AC or a timer? If the stabilizer is buzzing does it buzz with the lamp disconnected?
     
  3. Pgeobc

    Pgeobc Member

    Messages:
    123
    Joined:
    Jul 1, 2009
    Location:
    Indian Terri
    Shooter:
    Multi Format
    Well, it is either a ballast, such as that used on a fluorescent light or a transformer, likely. I could understand it being a relay, too. At any rate, these are replaceable.
     
  4. RidingWaves

    RidingWaves Member

    Messages:
    824
    Joined:
    Feb 22, 2006
    Location:
    Hawaii
    Shooter:
    35mm RF
    Well, what it was doing was the stabilizer unit was buzzing, when I removed the sensor probe wire the buzzing stopped (but I lost the stabilization). When I altered the knob brighter or darker it stopped buzzing, but at common settings it would buzz. I tried it again after a day and the buzz is gone, maybe the actual electrical line had some interference?