The APUG Blogs Rebuilt From The Ground Up! (previous blog entries still exist)

Discussion in 'APUG System Announcements' started by Sean, Feb 25, 2007.

  1. Sean

    Sean Admin Staff Member

    Messages:
    8,920
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    Hi All,

    The first phase of the blog rebuild is complete. The blog area is open to the public and subscribers can create/comment on blogs. The previous system was pretty terrible. This new system is one of the more complex things I have ever put together for APUG. I've done some testing and it looks to be functioning OK. There is still more to come with the blog but this is a great start. I am currently putting together tutorials for using the blog. For the more adventurous going into your blog profile via the blog page and clicking the 'edit' tab allows you to configure several items. You can also add images into your blogs now, this is a little tricky but the basics are to click the image upload icon in your editor, browse to your file, upload your file - once your file is uploaded into the upload window there will be a link next to it to "add" it to your blog entry. There is attachment functionality as well.

    It is my intention to give Subscribers a nice blog area which they can link to on their personal websites. Also to have a nice area for Special Guest bloggers to blog.

    Please report any bugs here, I am sure there will be a few. Some new features:

    -total code upgrade
    -over 10 modules installed and configured
    -new theme installed and design tweaked + new graphics
    -wysiwyg editor (most browsers will allow you to create content in microsoft word like fashion)
    -blog image uploads (have images within your blog posts)
    -attachments working
    -full listing of active bloggers
    -ability to have a "My Links" block on your blogs page
    -guest book for your blog that visitors can sign
    -RSS for all blogs
    -RSS for individual blogs
    -Single login for blogs/apug
    -most recent blog entry shows in your apug forum profile
    -link to view your blog shows when your name is clicked in forum threads
    -spell check coming soon
    -image gallery capability coming soon

    Thanks,
    Sean
     
    Last edited by a moderator: Feb 25, 2007
  2. Bob F.

    Bob F. Member

    Messages:
    3,984
    Joined:
    Oct 4, 2004
    Location:
    London
    Shooter:
    Multi Format
    Seems to be a shortage of carriage returns - can not use the ENTER key to start a new line. Or to be precise, I can enter them in the editor but they do not display in the blog.

    Cheers, Bob.
     
  3. Sean

    Sean Admin Staff Member

    Messages:
    8,920
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    Hi Bob, what browser are you using, I'll give it a try. Sean
     
  4. Sean

    Sean Admin Staff Member

    Messages:
    8,920
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    no issues for me in Firefox, IE6 and Camino browsers. There could be issues in Safari as I think the editor in Safari is barely supported.. I have not been too happy with Safari and will try Safari again when version3 is out, until then I am on OSX Tiger with Firefox 2.0
     
  5. Bob F.

    Bob F. Member

    Messages:
    3,984
    Joined:
    Oct 4, 2004
    Location:
    London
    Shooter:
    Multi Format
    Odd - I tried both Firefox 1.5 and IE 6... I'll restart my PC and try again.

    Cheers, Bob.
     
  6. Sean

    Sean Admin Staff Member

    Messages:
    8,920
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    ok, walk me through exactly what/how you typed and i'll try to reproduce it again. Thanks

    P.S. are you seeing the enhanced editor, it should look similar to microsoft word..
     
  7. Bob F.

    Bob F. Member

    Messages:
    3,984
    Joined:
    Oct 4, 2004
    Location:
    London
    Shooter:
    Multi Format
    Your PS was th clue I needed. Had to switch to "Full HTML" mode and edit the existing entry in that - that put the line feeds in.

    [edit]: Also when creating a new blog entry I have to use Full HTML mode to get the line feeds. Not a problem now I know.

    Cheers, Bob.
     
  8. jstraw

    jstraw Member

    Messages:
    2,703
    Joined:
    Aug 27, 2006
    Location:
    Topeka, Kans
    Shooter:
    Multi Format
    Some observations, Sean:

    Since the APUG navigation is absent on the blogs (as I believe it should be) you are leaving APUG-proper as soon as you click on the "Blogs" tab. I think it should open in a new window because there's no easy navigation back except for the "Visit APUG.ORG" link.

    For me to want to make this the linked blog on my personal website I'd need the ability to alter the display name on the blog from my APUG username to my own name. I'd also need to be able to add a link to the rest of my website that's as prominant as the rest of the blog navigation and probably have it included in that navigation.
     
  9. jstraw

    jstraw Member

    Messages:
    2,703
    Joined:
    Aug 27, 2006
    Location:
    Topeka, Kans
    Shooter:
    Multi Format
    It seems that added user links only show on the blogs to people that are logged into APUG.

    Ack! I can't remove a link?
     
    Last edited by a moderator: Feb 25, 2007
  10. jstraw

    jstraw Member

    Messages:
    2,703
    Joined:
    Aug 27, 2006
    Location:
    Topeka, Kans
    Shooter:
    Multi Format
    I just noticed that creating a user link on my blog shows up on the "Blog Homepage."

    I don't want every little thing I experiment with to appear there. I need to be able to create and use categories and "Blog Homepage" can be a category I use or don't use at my discretion.

    I also notice that the links to "Blog Homepage" and "Blog and Tutorial Help" go to the same Blog Homepage.

    I don't think this is ready for launch. I think this is not a beta yet...still alpha.

    I'm sorry Sean, there's a lot of good work here and it can be great but it's not ready to be live yet.
     
  11. Sean

    Sean Admin Staff Member

    Messages:
    8,920
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    Hi, access control issue i have now made userlinks available for public viewing. As for using your real name in the blog, go into your blog profile and the edit tab and you can put something in the "Blog Title" field such as "Your Name's Blog" and that will appear at the top of each page. As for editing/deleting links looking into it. Thanks for the feedback I'll try to address all the issues as best I can..
     
  12. Sean

    Sean Admin Staff Member

    Messages:
    8,920
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    I'll disable "Blog Tutorial Help" link for now as it's not ready. The blog is fine for those who want to use it through apug but yes as far as a more stand alone system it still needs work. It's far better than the previous system which was live so I see no harm having it running as is and continuously improving it.

    "I don't want every little thing I experiment with to appear there. I need to be able to create and use categories and "Blog Homepage" can be a category I use or don't use at my discretion."

    I am working on removing userlink entries from the blog homepage, and it should be possible to provide a checkbox on the blog entry page to "display on the main apug homepage", however the spirit of the blog is to be a community event where apuggers share their photo diaries. If people want to discuss their new car or the last movie they watched then an account at blogger.com would be better..
     
  13. Sean

    Sean Admin Staff Member

    Messages:
    8,920
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    oh J, figured out how to edit user links, if you view your public blog profile, click userlinks then in the userlinks list click on the userlink title, it then has an edit/delete tab.. I will try to make this far more accessible..
     
  14. Bob F.

    Bob F. Member

    Messages:
    3,984
    Joined:
    Oct 4, 2004
    Location:
    London
    Shooter:
    Multi Format
    Couple more, both in IE6 and Firefox 1.5...

    I can't get past the first page on the Blog Homepage. Clicking on any of the numbers or "next >" or "last >>"at the bottom of the page loads an empty page with the single word "error".

    And, paragraphs are missing on other people's blogs too. From playing with the editor, it looks like you need two CR/LF pairs to get a new paragraph in the new system editor and the conversion of entries from the old to new system only inserted one (or left out whatever code the blog system uses to distinguish a new paragraph).

    Cheers, Bob.
     
  15. jstraw

    jstraw Member

    Messages:
    2,703
    Joined:
    Aug 27, 2006
    Location:
    Topeka, Kans
    Shooter:
    Multi Format
    I can't figure this out. What is a public blog profile?
     
  16. Kevin Caulfield

    Kevin Caulfield Subscriber

    Messages:
    3,269
    Joined:
    Aug 3, 2004
    Location:
    Melbourne, A
    Shooter:
    Multi Format
    I can't seem to navigate to page 2 from page 1, using either a click on the "2" or a click on the "next". The page just comes up with "error" in the top left corner.
     
  17. Sean

    Sean Admin Staff Member

    Messages:
    8,920
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
  18. Sean

    Sean Admin Staff Member

    Messages:
    8,920
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    I see that too, will look for a fix, thanks for the info..
     
  19. jstraw

    jstraw Member

    Messages:
    2,703
    Joined:
    Aug 27, 2006
    Location:
    Topeka, Kans
    Shooter:
    Multi Format
  20. Sean

    Sean Admin Staff Member

    Messages:
    8,920
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    the page links in the blog footer are now fixed :smile: