Thought I broke my Maxxum 7000

Discussion in '35mm Cameras and Accessories' started by Wade D, Jul 15, 2009.

  1. Wade D

    Wade D Member

    Messages:
    901
    Joined:
    Feb 15, 2006
    Location:
    Jamul, CA
    Shooter:
    Multi Format
    I hadn't used it in some time so I went out and shot a roll of Ilford FP4. At the end of the roll the camera stopped and I thought it was jammed as it didn't rewind. After looking at the manual I remembered it doesn't have auto rewind and you have to push the little R button and slide the lever to the left. DOH!!!! Anyone else have senior moments like this?:rolleyes:
     
  2. mjs

    mjs Member

    Messages:
    1,125
    Joined:
    Mar 15, 2005
    Location:
    Elkhart, Ind
    Shooter:
    Multi Format
    Nope. Not us. Must just be you.

    :wink:
     
  3. mudman

    mudman Member

    Messages:
    330
    Joined:
    Jan 20, 2008
    Location:
    Saratoga Spr
    Shooter:
    Multi Format
    yup, first time I ever used a Contax 167MT. Thought it had broken. Also just went to use my FE and couldn't realize why it wouldn't fire. Then I realized I've never changed the battery in it and I bought it used almost a year ago.
     
  4. John Koehrer

    John Koehrer Subscriber

    Messages:
    6,416
    Joined:
    Apr 3, 2004
    Location:
    Montgomery,
    Shooter:
    Multi Format
    Senior moments? NEVER! What were we talking about?
     
  5. Shawn Rahman

    Shawn Rahman Subscriber

    Messages:
    1,000
    Joined:
    Sep 10, 2005
    Location:
    Whitestone, NY
    Shooter:
    Multi Format
    Maxxum 7000! My first and most beloved camera, and what I used to learn photography. Great to here that you are still using it.
     
  6. Wade D

    Wade D Member

    Messages:
    901
    Joined:
    Feb 15, 2006
    Location:
    Jamul, CA
    Shooter:
    Multi Format
    It's in great shape with a 28-200 Tamron lens. I shoot many formats and it was time to get the Maxxum back into action. A little memory jog and I'm good to go.:smile: