Toyo (Omega) 45E, Have I broken it?

Discussion in 'Large Format Cameras and Accessories' started by mitchins, Jun 25, 2014.

  1. mitchins

    mitchins Member

    Messages:
    49
    Joined:
    May 22, 2014
    Shooter:
    Medium Format
    Hi,
    I'm still very new to my large format camera, and whilst I was taking out the negative holder, the focusing screen mount came off from the braflok spring back (as far as i can tell this is what it is called).

    I do not know how to put it back on or even if i have damaged something.

    Could somebody take a look and advise me as to whether it's damaged or how it goes on, the manual does not say.
    I'm not sure how it's spring loaded, or if it's a spring at all - i was pulling it outwards to access the negative holder when it came off.

    attached are photos.

    IMG_3485.jpg IMG_3486.jpg IMG_3487.jpg IMG_3488.jpg
     
  2. analoguey

    analoguey Member

    Messages:
    1,085
    Joined:
    Jul 24, 2013
    Location:
    Bangalore, I
    Shooter:
    Multi Format
    Looks like the detachable international back, if you ask me. I dont have the same one so wont be able to tell you how to attach it back
     
  3. shutterfinger

    shutterfinger Member

    Messages:
    1,359
    Joined:
    Feb 25, 2013
    Location:
    San Francisco Peninsul
    Shooter:
    4x5 Format
    You've totally destroyed it so pack it up and send it to me as I'll be glad to take it off your hands for the cost of shipping. :D
    Joking aside,
    Your pictures are of the focus panel. The back is still attached to the camera.
    Look at your picture #2. The hooks are the camera side of the Graflok/International back's focus panel. Look at the back on the camera, there should be a tapered bar top and bottom with angled slots in them. They will slide inward toward the film plane and outward away from the film plane. Slide them until they are at their limit away from the film plane.
    Now hold the focus panel up to the camera back. There should be a vertical pin, top and bottom of the film plane that corresponds to the hook on the focus panel. Sit the focus panel on the camera back, hook side inward and open side of the hook to the right of the pin. When the focus panel fits flat against the camera back push it to the left until it snaps into place. You can also push in on the knurled/ribbed side of the hooks and then slide the focus panel into place. If the vertical pins on the camera are bent or broken take the camera to a repair shop and have it fixed.

    The focus panel is designed to be removable so that other camera back accessories can be attached to the camera easily.
    If you cannot get the focus panel reattached post a clear picture of the back of the camera.
    The focus panel should have 5 to 10 pounds of pull at the film holder insertion point when properly attached to the camera.
     
  4. mitchins

    mitchins Member

    Messages:
    49
    Joined:
    May 22, 2014
    Shooter:
    Medium Format
    Hi Guys,
    Took me a while to get round to trying to fix it, but still no luck.
    It goes on but just doesn't seem tight enough, anyone with any info is much appreciated as I'd love to do some more LF photography.

    [​IMG][​IMG][​IMG][​IMG]
     

    Attached Files:

  5. Jon Shiu

    Jon Shiu Subscriber

    Messages:
    2,822
    Joined:
    Dec 2, 2003
    Location:
    Elk, Califor
    Shooter:
    Plastic Cameras
    The tension springs have gotten out of place because you opened the back up too far. The springs are supposed to press down on the pivot arms. Yours springs have slipped past and need to be on the other side of the arms.

    I think you will have to pry the springs up and put the swinging arms back under them, unless there is some way to disassemble.

    After it's fixed, when you put the panel back on, there is no need to open the back, just lay it on flat, push the arms down from the back and slide slightly to hook the arms on. Good luck!

    Jon
    1.jpg 2.jpg
     
  6. mitchins

    mitchins Member

    Messages:
    49
    Joined:
    May 22, 2014
    Shooter:
    Medium Format
    Hallelujah!
    That makes all the sense in the world, I'll try this tonight.
    Thanks so much!
     
  7. APUGuser19

    APUGuser19 Member

    Messages:
    2,041
    Joined:
    Aug 29, 2014
    Shooter:
    35mm
    I had an Omega View once. Those parts might be aluminum or magnesium or the like. Springs are spring-steel. Don't break the body casting. GL
     
  8. mitchins

    mitchins Member

    Messages:
    49
    Joined:
    May 22, 2014
    Shooter:
    Medium Format
    Many thanks!
    I am happy to report that it is fixed.
    Jon Shiu was exactly correct with his assessment. After bending a stiff coat hanger to lasso the loose end of the flat spring and move it over the hooks latch it's snapped back onto the camera with lots of tension.
    It's ready for action!


    Sent from my iPhone using Tapatalk