Troubleshoot a Omega Super Chromega D

Discussion in 'Darkroom Equipment' started by markrewald, Jan 16, 2010.

  1. markrewald

    markrewald Member

    Messages:
    139
    Joined:
    Jun 12, 2005
    Location:
    Aurora, Co
    Shooter:
    Medium Format
    Howdy!

    I have a Omega D6 with a Omega Super Chromega D Dichroic attachment. Today while in the darkroom the Chromega just went dead. No fan, no light. Is this just a simple matter of changing the bulb or am I looking at replacing the Chromega D?

    Thanks!
     
  2. ic-racer

    ic-racer Member

    Messages:
    7,486
    Joined:
    Feb 25, 2007
    Location:
    Midwest USA
    Shooter:
    Multi Format
    What kind of power supply are you using. The 'Power Tower' (which is the 'standard' power supply and solid state timer stacked on top) or the newer Chromegatrol? The fan runs on 120v, so if that is out, either the fan is dead or there is a bad contact at the plug.

    Unless your Chromega got run over by a truck, it would be totally repairable, so there should be no need to replace it.
     
  3. markrewald

    markrewald Member

    Messages:
    139
    Joined:
    Jun 12, 2005
    Location:
    Aurora, Co
    Shooter:
    Medium Format
    UPDATE: Fan is working. So I am guessing it is just a burnt out bulb. Any suggestions on how to replace it since I don't have a manual?

    BTW. Thanks for responding.
     
  4. Neal

    Neal Subscriber

    Messages:
    1,626
    Joined:
    Dec 3, 2004
    Location:
    Chicago, Wes
    Shooter:
    Multi Format
    Dear markrewald,

    Just flip open the top and it will be obvious. Nothing to it.

    Neal Wydra
     
  5. markrewald

    markrewald Member

    Messages:
    139
    Joined:
    Jun 12, 2005
    Location:
    Aurora, Co
    Shooter:
    Medium Format
    wow... Don't I feel like an idiot. =)

    There are 2 lamps. One for the enlarging process and one for the front panel. Are the lamps on a circuit? In other words if one is out the other won't turn on? If thats the case how do I know which to replace? I have no lights to the unit at all.

    Thanks!
     
  6. Bob-D659

    Bob-D659 Member

    Messages:
    1,300
    Joined:
    Feb 10, 2008
    Location:
    Winnipeg, Ca
    Shooter:
    Multi Format
    If I'm not mistaken that head uses a common neutral for both bulbs and the 120 vac fan. The projector bulb is 24vac, I never looked at the indicator bulb to see what voltage is marked on it. I'd look for a wiring problem, maybe in the cord, the terminal strip in the head or the connector at the power supply.

    I just looked at the notes I have for that head, there are 4 wires in the cable, green - ground, white - neutral, black - 120vac, red - 24vac. Only the red is switched in the power supply as it goes directly to the 250 watt bulb. The fan and indicator lamp will both run on 120vac.
     
  7. Neal

    Neal Subscriber

    Messages:
    1,626
    Joined:
    Dec 3, 2004
    Location:
    Chicago, Wes
    Shooter:
    Multi Format
    Dear markrewald,

    The bulbs operate separately.

    Good luck,

    Neal Wydra
     
  8. iplincoln

    iplincoln Member

    Messages:
    1
    Joined:
    Feb 15, 2013
    Location:
    Campbell CA
    Shooter:
    4x5 Format
    Greetings,
    I am resurrecting a "Super Chromega D Dichroic II" which someone has put a "custom" PS on.
    The wires coming off the head are Red/Green/Black/White & >Brown< - looks like a factory-standard wiring harness. I don;t think they messed with the internals of the head itself - just put their own PS on it (e.g. didn;t conver to 120v as it's the standard 24v bulb, etc.)
    I've located a Omega "power-tower" w/the timer/PS & stabilizer as well as a suitable replacement 6+1 pin Jones-type plug which plugs into the corresponding stabilizer socket.

    Need some of your expert guidance on which color wire goes to which pin/blade on the replacement jones-type plug.
    Example: if I'm looking at the 6+1 pin plug straight-on, with the rod/orientation pin towards the top and the 6x blades vertical, which wire from the head goes to which blade?
    Please see below on how I'm thinking:
    Upper-left blade is ?
    Middle-left blade is ?
    Lower-left blade is ?
    Upper-right blade is ?
    Middle-right blade is ?
    Lower-right blade is ?
    Much thanks in advance,
    Ian L
     
  9. ic-racer

    ic-racer Member

    Messages:
    7,486
    Joined:
    Feb 25, 2007
    Location:
    Midwest USA
    Shooter:
    Multi Format
    This is the power supply schematic. You may have to open up your power supply and open up the color head and follow the wires back to see which goes where. I repaired one for a friend but it has been a while and I don't think I kept my notes. Either way you need to double and triple check things. The dichroic lamp needs 24V, the little indicator lamp and fan need 120V from what I recall.

    Realize the on-off switch on the transformer box has no effect on the voltage to the 24V lamp unless the timer is hooked up. Thus make sure the timer is hooked up correctly with the short 120v connecting plug on the back. I see you posted on Harry's forum, but even if you get the colors to pins exact, you really need to triple check all the voltages and trace the wires from the plug back into the head to be certain.
    Chromega.jpg