uniflex II

Discussion in 'Medium Format Cameras and Accessories' started by meghanlee, Jul 17, 2005.

  1. meghanlee

    meghanlee Member

    Messages:
    3
    Joined:
    Feb 2, 2005
    Shooter:
    35mm
    I found a uniflex II medium format at an antique store. I really didn't get much of a chance to check it out as I was in a hurry and just bought it when the guy offered it to me for 8 bucks but now I have realized that I am seeing no shutter in front of the lens. Anyone have some experience with this that could maybe let me know if it might be stuck somewhere in the body or if I'm just down 8 bucks?

    Thanks.
     
  2. Nick Zentena

    Nick Zentena Member

    Messages:
    4,679
    Joined:
    Nov 21, 2004
    Location:
    Italia
    Shooter:
    Multi Format
  3. meghanlee

    meghanlee Member

    Messages:
    3
    Joined:
    Feb 2, 2005
    Shooter:
    35mm
    its that one
    I know that hte bottom lens should have the shutter but it doesn't seem to be there somewhow, its like its stuck it the open position or something? I've opened it up and poked around a bit but am sort of lost as to where to go from there so yeah any ideas are welcome.
     
  4. Nick Zentena

    Nick Zentena Member

    Messages:
    4,679
    Joined:
    Nov 21, 2004
    Location:
    Italia
    Shooter:
    Multi Format
    You mean it looks open when you have the back of the camera open?

    If you read off the name of the shutter some one may know it.
     
  5. meghanlee

    meghanlee Member

    Messages:
    3
    Joined:
    Feb 2, 2005
    Shooter:
    35mm
    it looks almost like the shutter doesn't exist
    I think I'll have to take it somewhere, but thanks for helping, it was greatly appreciated
    if anything 8 bucks wasn't bad for a nice paperweight
     
  6. stark raving

    stark raving Member

    Messages:
    125
    Joined:
    Apr 27, 2005
    Location:
    Lumberton, N
    Shooter:
    35mm
    I think it's a simple self-cocking shutter. Blades are probably stuck open. I have one of those, it only works on one speed. I haven't fixed it or shot with it yet. Here's an idea: if you contact Rick Oleson at rick_oleson@yahoo.com he might send you some info on how to fix it yourself. The self-cocking shutters are supposed to be relatively simple.

    Jonathan