Update on APUG server performance issues..

Discussion in 'APUG System Announcements' started by Sean, Apr 10, 2012.

  1. Sean

    Sean Admin Staff Member

    Messages:
    8,952
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    Hi All,

    Some strange issues with the server lately. We seem to run like lightning for months or days, then have periods of extreme slowness. I've been working with the host and some comprehensive monitoring has been installed on the server. With the monitoring in place we now have to sit back and wait for the slowness to occur. Once this happens we should be able to see exactly what is causing it. I just wanted to keep you in the loop and updated. I know it's hugely frustrating to come to the site and all of a sudden it takes a minute for a page to load.

    It would be helpful if you notice the slow response times to email me as soon as possible at apug.org@gmail.com -that will give us a time stamp to examine the reports.

    Other options will be moving the database to a dedicated database server. However after discussing with the host they feel it is best to see what is happening with the slow downs first. It could be something minor and easily fixed.

    Thanks,
    Sean
     
  2. zsas

    zsas Member

    Messages:
    1,962
    Joined:
    May 12, 2011
    Location:
    Chicago, IL
    Shooter:
    35mm RF
    Thanks for the update, will let you know the next spell, which hopefully never appears again, maybe you scattered the data gnomes, posts like these that put the gnomes on alert to our plan to monitor their behavior sometimes has a sentinel effect
     
  3. dehk

    dehk Member

    Messages:
    891
    Joined:
    Aug 4, 2010
    Location:
    W Michigan
    Shooter:
    Multi Format
    Will do on the email!

    Keep up the good work!
     
  4. Sean

    Sean Admin Staff Member

    Messages:
    8,952
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    The new monitoring is starting to pay off. It's identified several issues already. A few software updates and cpu usage is down 50%. Average response time of 577ms is continuing to drop, currently at 350ms. Will keep at it.
     
  5. Sean

    Sean Admin Staff Member

    Messages:
    8,952
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    *update: Another big round of tweaks and things are really flying now. From what I can see everything is ok but post here if you notice anything odd. About the only issue I see is pagination on the Portfolios page needs adjusting. I'll get to that soon.

    Thanks,
    Sean

    *update: 2 more glitches. 1) an issue with social groups home page buttons overlapping. 2) stats not loading on the home page.

    Will have to fix these in the morning
     
  6. pstake

    pstake Member

    Messages:
    715
    Joined:
    May 5, 2005
    Shooter:
    Multi Format
    Recent Activity is not loading on the home page, for me. Maybe that's what you meant by "stats not loading on the home page?"

    Just letting you know.
     
  7. Marco B

    Marco B Member

    Messages:
    2,981
    Joined:
    Jan 13, 2005
    Location:
    The Netherla
    Shooter:
    Multi Format
    Same here, the list of Recent Activity on APUG's home page is not showing / loading at all. Frame for Recent Activity shows, but stays empty, no threads are listed. The word "loading" stays visible.
     
  8. brucemuir

    brucemuir Member

    Messages:
    2,266
    Joined:
    Dec 25, 2007
    Location:
    Metro DC are
    Shooter:
    Multi Format
    Same here
    Safari 5.1.5
    OSX 10.7.3
     
  9. mjs

    mjs Member

    Messages:
    1,121
    Joined:
    Mar 15, 2005
    Location:
    Elkhart, Ind
    Shooter:
    Multi Format
    Could not log in from home page using IE 8 or Opera 11.62. Can log in from subsequent "you have to create an account to use this site" page. Odd behavior on home page: previously when I clicked on User Name the text box cleared and the cursor went to the left edge. Now the text in the box ("User Name") does not clear and cursor goes to where the mouse pointer was. Additionally, if you use the Back button on your browser to return to the home page after an unsuccessful login, your user name is in the user name box and the password box appears empty but if you highlight it with your mouse, your password appears in the password box in plain text.

    Mike
     
  10. darkosaric

    darkosaric Subscriber

    Messages:
    2,862
    Joined:
    Apr 15, 2008
    Location:
    Hamburg, DE
    Shooter:
    Multi Format
    same also for me: ubuntu, firefox.
     
  11. Sean

    Sean Admin Staff Member

    Messages:
    8,952
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    login box (top right) should be ok now. If anyone wants to test that would be great. The homepage loads fine, but there is a glitch with the stats box so looking into that.
     
  12. papagene

    papagene Membership Council

    Messages:
    5,282
    Joined:
    Jun 11, 2004
    Location:
    Western Mass
    Shooter:
    Multi Format
    Logged out and back in OK. Though Recent Activity is still missing.
    Using Firefox... same for Opera and Chrome.
     
  13. Sean

    Sean Admin Staff Member

    Messages:
    8,952
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    Thanks, yeah recent activity is being a pain after the upgrade.
     
  14. Sponsored Ad
  15. zsas

    zsas Member

    Messages:
    1,962
    Joined:
    May 12, 2011
    Location:
    Chicago, IL
    Shooter:
    35mm RF
    Looks good!


    Yep see what you mean, see it on iPhone IOS 5 and PC Vista, IE9 and Firefox 3.6
     
  16. Mark Crabtree

    Mark Crabtree Member

    Messages:
    678
    Joined:
    Apr 21, 2009
    Shooter:
    Large Format
    Still no recent activity on the home page. Hard to keep up with the forums without that unless you've got a lot of time to check on each.

    Mac 10.6
    Firefox 11
     
  17. ME Super

    ME Super Member

    Messages:
    1,151
    Joined:
    Apr 17, 2011
    Location:
    Central Illi
    Shooter:
    35mm
    ^^^
    Until Sean has the recent activity boxes fixed, here's an alternate method for seeing the recent posts. Click "Forum" at the top of the page. When the new page loads, on the lighter gray bar underneath "Forum" is a link marked "Today's posts."

    It's not quite the same, but it's close enough until Sean gets that fixed. I'm not worried, he'll git'r done.
     
  18. Mark Crabtree

    Mark Crabtree Member

    Messages:
    678
    Joined:
    Apr 21, 2009
    Shooter:
    Large Format
    Thanks for the tip. I'd always gone in the front door, and had never noticed that. Now I'll be able to sleep better having caught up on what everyone has been up to.
     
  19. Jerevan

    Jerevan Subscriber

    Messages:
    1,968
    Joined:
    Nov 19, 2004
    Location:
    Sweden/Germany
    Shooter:
    35mm
    I still have the issue with cleartext passwords with the new login box on Safari (os x 10.6) and on Firefox 11 as before. Never use Safari for APUG so doesn't seem to be a cookie issue.
     
  20. MattKing

    MattKing Subscriber

    Messages:
    15,219
    Joined:
    Apr 24, 2005
    Location:
    BC, Canada
    Shooter:
    Multi Format
    And please, please remove the "Like" button on the right hand side!!!!
     
  21. Sean

    Sean Admin Staff Member

    Messages:
    8,952
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    oops :smile: must have gotten switched on when i upgraded the seo system. stand by...
     
  22. Sean

    Sean Admin Staff Member

    Messages:
    8,952
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    We seems to be having performance problems again, investigating now. Thanks
     
  23. Sean

    Sean Admin Staff Member

    Messages:
    8,952
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    We seems to be having performance problems again today, investigating now. Thanks
     
  24. Kevin Caulfield

    Kevin Caulfield Subscriber

    Messages:
    3,271
    Joined:
    Aug 3, 2004
    Location:
    Melbourne, A
    Shooter:
    Multi Format
    It seems fine right now, but half an hour ago it was s l o w.
     
  25. Sean

    Sean Admin Staff Member

    Messages:
    8,952
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    yeah, I think we're narrowing it down to a db table that gets out of whack.
     
  26. Poisson Du Jour

    Poisson Du Jour Member

    Messages:
    3,941
    Joined:
    Jul 1, 2008
    Location:
    ɹǝpunuʍop. F
    Shooter:
    Multi Format
    8.04am AEST Tuesday: pages are running a little slow on call-up; this seems variable, some pages are fast, others are not.
    Yesterday the site was blazing along with consummate swiftness, today hasn't been all that enchanting. My major gripe though is with the redesign of the posts page on entry. What can be added to a chorus that generally does not like the new look??