using a strobe with my Kodak portrait lens

Discussion in 'Large Format Cameras and Accessories' started by echard, Jan 29, 2012.

  1. echard

    echard Subscriber

    Messages:
    38
    Joined:
    Feb 5, 2004
    Location:
    virginia bea
    Shooter:
    35mm RF
    Hi All, I'm trying to figure out if it's possible to get my strobe sync cords to work with this old lens on my 8x10. It has an old two pronged thing. Not a modern pc terminal. Is there a work around or cord adapter?

    Thanks
    Echard
     
  2. jnanian

    jnanian Advertiser Advertiser

    Messages:
    19,982
    Joined:
    Jun 21, 2003
    Location:
    local
    Shooter:
    Multi Format
    paramount makes ( still ) a a 2 prong syc that you can probably find online, here in the classifieds
    or get special ordered for you at your local photo store.

    http://paramountcords.com/Bipost.asp

    ( or directly through paramount :smile: )

    have fun!

    john
     
  3. echard

    echard Subscriber

    Messages:
    38
    Joined:
    Feb 5, 2004
    Location:
    virginia bea
    Shooter:
    35mm RF
    Nice! Thanks John!

    Cheers,
    Echard
     
  4. jp498

    jp498 Member

    Messages:
    1,467
    Joined:
    Oct 5, 2009
    Location:
    Owls Head ME
    Shooter:
    Multi Format
    Small alligator clips will work too if you don't want to wait for a cord to show up. I'm also told the ilex5 shutter it uses doesn't have a detent for the x-sync setting, so one should fire it with strobes hooked up while observing the ground glass to make sure the x-sync setting is selected.