We're back! The System updates were successful. Please report any problems here.

Discussion in 'APUG System Announcements' started by Sean, Sep 25, 2010.

  1. Sean

    Sean Admin Staff Member Admin

    Messages:
    9,339
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    The core foum software has been updated 2 point releases from 4.0.5 to 4.0.7 (this addresses over 300 bugs in the software). The Gallery software has also been updated from release candidate1 to release candidate2. You may find some forum and gallery issues fixed, and you may find a few items broken by the updates so please let me know. I think it is in good enough shape for me to continue tomorrow. I also have several features going in tomorrow such as subscribe to users posts, view single posts (for printing a single post), and more.

    Thanks,
    Sean
     
  2. Sean

    Sean Admin Staff Member Admin

    Messages:
    9,339
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    just fyi- ran into problems getting memcached running so will work on that later (it is a performance boosting system that ties into the forum system)
     
  3. Marco B

    Marco B Member

    Messages:
    2,981
    Joined:
    Jan 13, 2005
    Location:
    The Netherla
    Shooter:
    Multi Format
    Congratulations with the successful upgrade. I noticed at least one already fixed issue: users homepage links in the "mini-user profiles" in forum view is now working properly taking you to the homepages and no longer falsely appending the APUG URL to it.

    Two quick observations though:
    - That homepage link bails you out of APUG now. Not a real issue, but you may wish to set the links to open in a "blank" page / new TAB.
    - Some of the forum page links above threads with multiple pages, no longer use the APUG color sheme, but are now the probably default vBulletin blue color. See the blue arrows for "last page" etc.
     
  4. Sean

    Sean Admin Staff Member Admin

    Messages:
    9,339
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    Thanks, I plan to go through the bug thread soon and get reorganized.
     
  5. rrankin

    rrankin Member

    Messages:
    866
    Joined:
    May 27, 2005
    Location:
    La Plata, Mi
    Shooter:
    Large Format
  6. Ian Grant

    Ian Grant Subscriber

    Messages:
    18,141
    Joined:
    Aug 2, 2004
    Location:
    West Midland
    Shooter:
    Multi Format
    You've lost the APUG favicon.ico

    Ian
     
  7. Sean

    Sean Admin Staff Member Admin

    Messages:
    9,339
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    Fixed the favicon, thanks
     
  8. Jerevan

    Jerevan Subscriber

    Messages:
    2,034
    Joined:
    Nov 19, 2004
    Location:
    Sweden/Germany
    Shooter:
    35mm
    On the frontpage, clicking the small arrow on the right, beside a thread, to get to the latest reply in that thread gets me a "No thread specified" on Firefox 3.6.10 on Win XP.
     
    Last edited by a moderator: Sep 28, 2010
  9. Anon Ymous

    Anon Ymous Member

    Messages:
    1,479
    Joined:
    Feb 7, 2008
    Location:
    Greece
    Shooter:
    35mm
    Yes, I notified the admin as the error message says some time ago, but it's still problematic. There's a "=" character after the thread number at the URL, which ruins it. Additionally, the post number at the link will get you to the last post of the thread, not the first unread. IMHO, it would be better if the URL text stopped at "goto=newpost", which seems to get you to the first unread.
     
  10. Sirius Glass

    Sirius Glass Subscriber

    Messages:
    20,720
    Joined:
    Jan 18, 2007
    Location:
    Southern California
    Shooter:
    Multi Format
    Still, if you have more than 100 posts to view, the number of pages and the post count shows 5 pages and 100 posts. The New Posts is unable to show the number of New Posts it has for you.

    Steve
     
  11. Sean

    Sean Admin Staff Member Admin

    Messages:
    9,339
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    I think it will if you go to page5 it then ads more pages. I think the idea is to keep the server from getting pegged returning 3,000 results at once so it shows 100 or so then if you hit the last page it pulls the rest..
     
  12. Kevin Caulfield

    Kevin Caulfield Subscriber

    Messages:
    3,407
    Joined:
    Aug 3, 2004
    Location:
    Melbourne, A
    Shooter:
    Multi Format
    One bug which is still here is that when the first line of somebody's post ends right at the last character position of that first line, then that word is repeated as the first word of the second line. This only happens when that last word on the first line ends in that exact last position.

    There is also a new bug now when you look at new posts, the bar which contains the page numbers at the top right has its top half missing. It is still selectable though, and you can just about make out the numbers. The page bar at the bottom right is fine though.
     
  13. Sean

    Sean Admin Staff Member Admin

    Messages:
    9,339
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    I can't seem to duplicate that, what OS and browser are you on? thankls
     
  14. Sponsored Ad
  15. Kevin Caulfield

    Kevin Caulfield Subscriber

    Messages:
    3,407
    Joined:
    Aug 3, 2004
    Location:
    Melbourne, A
    Shooter:
    Multi Format
    Windows XP and IE 7.
     
  16. Kevin Caulfield

    Kevin Caulfield Subscriber

    Messages:
    3,407
    Joined:
    Aug 3, 2004
    Location:
    Melbourne, A
    Shooter:
    Multi Format
    If it's just peculiar to my set-up that's fine. I can live with those little glitches.
     
  17. Sean

    Sean Admin Staff Member Admin

    Messages:
    9,339
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
  18. Kevin Caulfield

    Kevin Caulfield Subscriber

    Messages:
    3,407
    Joined:
    Aug 3, 2004
    Location:
    Melbourne, A
    Shooter:
    Multi Format
    I can, Sean, if you can tell me a quick and easy way to capture a screen shot?
     
  19. Marco B

    Marco B Member

    Messages:
    2,981
    Joined:
    Jan 13, 2005
    Location:
    The Netherla
    Shooter:
    Multi Format
    How to capture a screen shot for bug reports

    I see you are on Windows. It is very easy:

    - Open a new Word or OpenOffice document
    - Go back to APUG and replicate the bug on screen
    - If you see the problem, hit the "Prt Scr" (print screen) button. It is usually located somewhere in the upper right corner of your keyboard. Ironically, contrary to what you might expect, this doesn't "print-your-screen" to your "all-in-one" printer, but copies the entire screen content as an image... The name of the button may be some remnant of the 1970's technology prehistoric PC's when the button probably did "print-your-screen"... :D They never updated keyboards though :wink:
    - Go back to Word or OpenOffice, and choose Edit/Paste from the menu or hit "Ctrl+v" (hit the v button while holding down the Ctrl button) which is the same. The screen shot should now appear as an image in your Word document.
    - Save the Word or Openoffice document, and e-mail it to Sean.

    Marco
     
  20. Kevin Caulfield

    Kevin Caulfield Subscriber

    Messages:
    3,407
    Joined:
    Aug 3, 2004
    Location:
    Melbourne, A
    Shooter:
    Multi Format
    Thanks, Marco. You are a legend. Examples coming to Sean shortly.
     
  21. lxdude

    lxdude Member

    Messages:
    6,907
    Joined:
    Apr 8, 2009
    Location:
    Redlands, So
    Shooter:
    Multi Format
    Back in the old CP/M days it was called a "screen dump". And it was normally configured to go to the printer.
     
  22. Kevin Caulfield

    Kevin Caulfield Subscriber

    Messages:
    3,407
    Joined:
    Aug 3, 2004
    Location:
    Melbourne, A
    Shooter:
    Multi Format
    On my keyboard it is "prt sc".
     
  23. Marco B

    Marco B Member

    Messages:
    2,981
    Joined:
    Jan 13, 2005
    Location:
    The Netherla
    Shooter:
    Multi Format
    Yes, that is what I was suspecting. That mainframe time is a bit before my time though... The most archaic I have worked with, were non-networked PCs without hard disk, that needed to be booted from 5 1/4 inch floppy disks to start up DOS... That was in 1990 when I started my university studies. They were replaced by hard disk based 286's pretty soon afterwards though...
     
  24. Q.G.

    Q.G. Inactive

    Messages:
    5,682
    Joined:
    Jul 23, 2007
    Location:
    Netherlands
    Shooter:
    Medium Format
    Don't paste into Word (why use a wordprocessor to handle images?), paste into Paint, and save as JPEG.
    Then you can upload the image to the thread itself.
     
  25. MattKing

    MattKing Subscriber

    Messages:
    17,191
    Joined:
    Apr 24, 2005
    Location:
    Delta, BC, Canada
    Shooter:
    Multi Format
    What he said.

    When you are working in Paint, I find that it helps if, before you paste in the image, you set "Page Setup" (under the File menu) to landscape orientation.
     
  26. Sean

    Sean Admin Staff Member Admin

    Messages:
    9,339
    Joined:
    Aug 29, 2002
    Location:
    New Zealand
    Shooter:
    Multi Format
    Thanks guys, got the screens and will look into it as soon as some of my backlog is cleared